MinimServer Forum

Full Version: problem adding to queue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
(03-03-2014 21:50)Peter StreamMagic Wrote: [ -> ]Hello Simon,
I have done what you asked, but I have a feeling you misunderstood the problem. It seems that you think the problem is related to one specific album, but it refers to all albums.
I will specify the problem for you:
I select a map, f.i. genre, then I select one album from this map and add it to the queue. When I go to the queue all the tracks of all the albums from the selected map are put in the queue.

Regards,
Peter.

Hi Peter,
I did understand your problem description.

This log contains the same information as you posted previously. This means the Stream Magic app is preloading the full contents of the library (using UPnP Search) as part of step 2). Because Trace hasn't been enabled at this time, the saved log doesn't contain the information that I need. To get this information, it will be necessary to use a different approach. What kind of NAS are you using to run MinimServer?

Simon
(04-03-2014 00:05)simoncn Wrote: [ -> ]
(03-03-2014 21:50)Peter StreamMagic Wrote: [ -> ]Hello Simon,
I have done what you asked, but I have a feeling you misunderstood the problem. It seems that you think the problem is related to one specific album, but it refers to all albums.
I will specify the problem for you:
I select a map, f.i. genre, then I select one album from this map and add it to the queue. When I go to the queue all the tracks of all the albums from the selected map are put in the queue.

Regards,
Peter.

Hi Peter,
I did understand your problem description.

This log contains the same information as you posted previously. This means the Stream Magic app is preloading the full contents of the library (using UPnP Search) as part of step 2). Because Trace hasn't been enabled at this time, the saved log doesn't contain the information that I need. To get this information, it will be necessary to use a different approach. What kind of NAS are you using to run MinimServer?

Simon
(04-03-2014 00:27)Peter StreamMagic Wrote: [ -> ]
(04-03-2014 00:05)simoncn Wrote: [ -> ]
(03-03-2014 21:50)Peter StreamMagic Wrote: [ -> ]Hello Simon,
I have done what you asked, but I have a feeling you misunderstood the problem. It seems that you think the problem is related to one specific album, but it refers to all albums.
I will specify the problem for you:
I select a map, f.i. genre, then I select one album from this map and add it to the queue. When I go to the queue all the tracks of all the albums from the selected map are put in the queue.

Regards,
Peter.

Hi Peter,
I did understand your problem description.

This log contains the same information as you posted previously. This means the Stream Magic app is preloading the full contents of the library (using UPnP Search) as part of step 2). Because Trace hasn't been enabled at this time, the saved log doesn't contain the information that I need. To get this information, it will be necessary to use a different approach. What kind of NAS are you using to run MinimServer?

Simon
Hi Simon,

The NAS is a QNAP TS 119-P II.
I also use a windows XP pro Pc with 0.72 installed and a windows 7 PC with 0.81 MinimServer as server.
It makes no difference which one I use ,in all cases the problem occurs.

Peter.
(04-03-2014 00:40)Peter StreamMagic Wrote: [ -> ]Hi Simon,

The NAS is a QNAP TS 119-P II.
I also use a windows XP pro Pc with 0.72 installed and a windows 7 PC with 0.81 MinimServer as server.
It makes no difference which one I use ,in all cases the problem occurs.

Peter.

OK, this makes it quite easy to get the information I need. Please do the following:

1) Power off the Stream Magic player
2) Power off the device you are using to run the Stream Magic app
3) From the QPKG Center, disable and enable MinimServer
4) From the minim icon, select 'Show log'
5) From the log window, set the MinimServer logging level to Trace
6) Close the log window
7) Power on the Stream Magic player
8) Start the Stream Magic app
9) Add the tracks of one album to the queue. The complete genre will be added instead.
10) From the minim icon, select 'Show log'
11) From the log window, set the MinimServer logging level to Info
12) Close the log window
13) Copy the minimserver.log file from the Public share of the QNAP to a Windows PC
14) Zip the minimserver.log file and upload it to my FTP server. I will PM you the server details now.

Many thanks!
Please also let me know which was the album you added to the queue. This will probably not be clear from the minimserver.log file.
(04-03-2014 00:52)simoncn Wrote: [ -> ]
(04-03-2014 00:40)Peter StreamMagic Wrote: [ -> ]Hi Simon,

The NAS is a QNAP TS 119-P II.
I also use a windows XP pro Pc with 0.72 installed and a windows 7 PC with 0.81 MinimServer as server.
It makes no difference which one I use ,in all cases the problem occurs.

Peter.

OK, this makes it quite easy to get the information I need. Please do the following:

1) Power off the Stream Magic player
2) Power off the device you are using to run the Stream Magic app
3) From the QPKG Center, disable and enable MinimServer
4) From the minim icon, select 'Show log'
5) From the log window, set the MinimServer logging level to Trace
6) Close the log window
7) Power on the Stream Magic player
8) Start the Stream Magic app
9) Add the tracks of one album to the queue. The complete genre will be added instead.
10) From the minim icon, select 'Show log'
11) From the log window, set the MinimServer logging level to Info
12) Close the log window
13) Copy the minimserver.log file from the Public share of the QNAP to a Windows PC
14) Zip the minimserver.log file and upload it to my FTP server. I will PM you the server details now.

Many thanks!

Hi Simon,
I am very sorry but I made a mistake!!
The 0.72 version doesnt add more than one album (they almost have the same name).
It is getting to late for me, sorry.

Peter.
(04-03-2014 01:13)Peter StreamMagic Wrote: [ -> ]Hi Simon,
I am very sorry but I made a mistake!!
The 0.72 version doesnt add more than one album (they almost have the same name).
It is getting to late for me, sorry.

Peter.

The 0.72 version doesn't use UPnP Search. If there is a problem with UPnP Search, it will only affect 0.8.1. If 0.8.1 isn't working correctly, please produce a minimserver.log file as I requested.
(01-03-2014 21:39)Peter StreamMagic Wrote: [ -> ]
(01-03-2014 18:10)bossinga Wrote: [ -> ]Hello,

I have the same problem with my stream magic 6.
Any word from Cambridge Audio?

cheers!

Hello ,

CA latest Firmware update(V266-b-553) should solve the problem.
In my case it doesnt .
When I try to add one album to queue it adds all albums of the selected genre.
I use a Beta app 4.1.17(8207) it may respond diffrent than the "normal " app.

Peter.

Peter, I only see v266-b-546 firmware. Where did you get the new FW from? (also on the device itself I see no update)

cheers,
Stefan
(04-03-2014 19:54)bossinga Wrote: [ -> ]
(01-03-2014 21:39)Peter StreamMagic Wrote: [ -> ]
(01-03-2014 18:10)bossinga Wrote: [ -> ]Hello,

I have the same problem with my stream magic 6.
Any word from Cambridge Audio?

cheers!

Hello ,

CA latest Firmware update(V266-b-553) should solve the problem.
In my case it doesnt .
When I try to add one album to queue it adds all albums of the selected genre.
I use a Beta app 4.1.17(8207) it may respond diffrent than the "normal " app.

Peter.

Peter, I only see v266-b-546 firmware. Where did you get the new FW from? (also on the device itself I see no update)

cheers,
Stefan

Hi Stefan,

I joined a beta test program in order to improve the streammagic app.
(C A asked me to join) It may be that also the firmware is related to this beta testing.

cheers,

Peter
(01-03-2014 21:39)Peter StreamMagic Wrote: [ -> ]Hello ,

CA latest Firmware update(V266-b-553) should solve the problem.
In my case it doesnt .
When I try to add one album to queue it adds all albums of the selected genre.
I use a Beta app 4.1.17(8207) it may respond diffrent than the "normal " app.

Peter.

This problem is caused by a bug in MinimServer that causes some UPnP Search queries to return incorrect results. It is now fixed in MinimServer update 22.
Pages: 1 2 3 4
Reference URL's