Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Songs with an apostrophe
30-04-2020, 19:20
Post: #1
Songs with an apostrophe
Hello,

I would like to ask a question about searching my library from a control point app on an iPad and searching to a song name that contains an apostrophe. Basically for me at least, this doesn't work on either of the Linn control points or the Lumin one.

I have probably wrongly gone for simple text in my file and song names and an apostrophe is ascii code 39 or hex27 everywhere.

Can I fix this or am I stuck with it?

Thanks for your help.


Cheers,

Bob.
Find all posts by this user
Quote this message in a reply
30-04-2020, 19:50
Post: #2
RE: Songs with an apostrophe
It is likely that the song you are searching for contains the "wrong kind" of apostrophe (Unicode rather than ASCII). if you look closely, you should be able to see a slight difference in the shape.

ASCII hex 27: '
Unicode right single quotation mark (U+2019): ’
Unicode left single quotation mark (U+2018): ‘

There might be others.
Find all posts by this user
Quote this message in a reply
30-04-2020, 19:56
Post: #3
RE: Songs with an apostrophe
(30-04-2020 19:50)simoncn Wrote:  It is likely that the song you are searching for contains the "wrong kind" of apostrophe (Unicode rather than ASCII). if you look closely, you should be able to see a slight difference in the shape.

ASCII hex 27: '
Unicode right single quotation mark (U+2019): ’
Unicode left single quotation mark (U+2018): ‘

There might be others.

Hi,
Thanks for the quick reply.
I have been very careful building the library and I'm certain that the apostrophies are simple ascii codes both as the file name and the tag.

I think the problem is that the control point apps are searching for unicode versions but I'm not an expert.

Cheers,

Bob.
Find all posts by this user
Quote this message in a reply
30-04-2020, 21:12
Post: #4
RE: Songs with an apostrophe
You are exactly correct, at least for Kazoo running on an iPad. It searches for U+2019 instead of 0x27.
Find all posts by this user
Quote this message in a reply
01-05-2020, 07:16
Post: #5
RE: Songs with an apostrophe
There is a fix for this described in this thread. I have tried it and it works.
Find all posts by this user
Quote this message in a reply
01-05-2020, 14:10
Post: #6
RE: Songs with an apostrophe
(01-05-2020 07:16)simoncn Wrote:  There is a fix for this described in this thread. I have tried it and it works.

Thank you so much. That does seem to fix my problem.

Brilliant.

Bob.
Find all posts by this user
Quote this message in a reply
01-05-2020, 15:14
Post: #7
RE: Songs with an apostrophe
Now I seem to have a problem. When I search my library for a track it works fine now and finds the track but puts an error in the Minimserver log file:
MinimServer[RED] is running
MinimServer: 0$=Description$47873 isn't a valid object
MinimServer: 0$=Description$47873 isn't a valid object
MinimServer: incorrect format for object ID '"I don't want to"'
Find all posts by this user
Quote this message in a reply
01-05-2020, 16:59
Post: #8
RE: Songs with an apostrophe
Did these log messages appear when you did the search or did they appear after you had done a MinimServer rescan? If they appeared after a rescan, the first message is a known issue with Kazoo. I haven't seen the second message before.
Find all posts by this user
Quote this message in a reply
01-05-2020, 19:11
Post: #9
RE: Songs with an apostrophe
(01-05-2020 16:59)simoncn Wrote:  Did these log messages appear when you did the search or did they appear after you had done a MinimServer rescan? If they appeared after a rescan, the first message is a known issue with Kazoo. I haven't seen the second message before.

I've just tried this again and got this in the log just after doing the search not after doing a rescan.

MinimServer: incorrect format for object ID '"I don't want to talk"'

I didn't realise this could be caused by the control point app, I prefer Lumin to either of the Linn apps. Yes, it has flaws like it can't pick up another player without restarting the app but I love the layout. Could it be this is a Lumin issue?

Cheers,

Bob.
Find all posts by this user
Quote this message in a reply
01-05-2020, 19:40
Post: #10
RE: Songs with an apostrophe
(01-05-2020 19:11)mightyoakbob Wrote:  
(01-05-2020 16:59)simoncn Wrote:  Did these log messages appear when you did the search or did they appear after you had done a MinimServer rescan? If they appeared after a rescan, the first message is a known issue with Kazoo. I haven't seen the second message before.

I've just tried this again and got this in the log just after doing the search not after doing a rescan.

MinimServer: incorrect format for object ID '"I don't want to talk"'

I didn't realise this could be caused by the control point app, I prefer Lumin to either of the Linn apps. Yes, it has flaws like it can't pick up another player without restarting the app but I love the layout. Could it be this is a Lumin issue?

Cheers,

Bob.
I use Lumin app and I have three renderers, I have all them available in the app .... I’m using Bubbleupnpserver to be able to find them as openhome players.
I’ve just tried a search for a name with apostrophe, an Album Artist, and Lumin cannot find it but no errors or warnings are shown in the log.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)