Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimserver keeps 'disappearing'
11-05-2019, 12:33
Post: #1
Minimserver keeps 'disappearing'
Greetings!

I've got an issue that the Minimserver that's running on my QNAP TS251A seems to only be intermittently visible on my LAN. I've got a feeling it's not a problem with minimserver itself, but more with the NAS or possibly the network.

When I search for Media Servers in either HiFi Cast app or in the Yamaha Musiccast app, sometimes both MinimServer and the NAS itself show up, sometimes only one of them, and sometimes none at all. Rebooting the NAS, router, switch or Wifi mesh sometimes fixes the problem, but more often than not doesn't.

Has anyone else had this problem, and if so did you manage to find the root cause? Could it be a problem with the NAS's own media server clashing with MinimServer? (I also have Plex running for movies).

My set up is:

NAS <-> Netgear switch <-> Mikrotik router <-> BT WholeHome WiFi <-> Devices

Any and all suggestions welcomed!
Find all posts by this user
Quote this message in a reply
11-05-2019, 15:06
Post: #2
RE: Minimserver keeps 'disappearing'
This is very likely to be caused caused by a network issue with UPnP multicast discovery messages not being passed correctly by one of your network components. If any of these components is using IGMP snooping, this can cause the problems that you are seeing.

A useful approach in cases like this is to isolate the cause by reducing network connections to the point where everything works correctly. For example, you could bypass the mesh by connecting your control point to the router's wi-fi network (if your router has wireless capability) or by connecting a control point app running on a wired device (e.g., PC or Mac) to the router. You could bypass the router and the mesh by connecting a wired control point to the switch. When you have found a stable working setup, you can add back connections one step at a time until the fault reappears.
Find all posts by this user
Quote this message in a reply
11-05-2019, 17:49
Post: #3
RE: Minimserver keeps 'disappearing'
FWIW: My MinimServer, running on an Asus Win10 Pro notebook, has shown the same behaviour for months. It would be visible on the network for a while (and invariably after a considerable delay) but then, for reasons unknown, would disappear again. The Asus was connected to my LAN via WiFi. I recently - as a last resort - decided to disable the WiFi and connect the Asus notebook to a gigabit LAN port of an Apple Airport Extreme base station via ethernet. Now all devices (various internet radios and a smart TV used as UPnP renderers) can see MinimServer immediately. So in my case the notebook's WiFi connection was the culprit.
Find all posts by this user
Quote this message in a reply
12-05-2019, 18:01
Post: #4
RE: Minimserver keeps 'disappearing'
Thanks both. Simon, is the recommendation that IGMP snooping should be disabled and UPnP (internal) enabled? My router claims to support both, but both the switch and the WiFi mesh don't seem to have a config option for them.

I've just bought a managed switch, so will try that and will then look to replace the WiFi mesh with the routers built-in WiFi, and will see if that fixes it.

I'll report back on the results!

Kevin
Find all posts by this user
Quote this message in a reply
12-05-2019, 19:46
Post: #5
RE: Minimserver keeps 'disappearing'
IGMP snooping should be disabled unless you have a degree in network engineering and know how it should be configured to work reliably. Smile

UPnP (internal) should be enabled. Often this is just about the router itself being visible using UPnP but it does no harm and might help in some cases.

These problems can be very difficult to solve. Debugging by substitution will get you there in the end but may require spending money on the substitute equipment.

The problems usually involve routers and wireless or powerline connections. Switches and wired Ethernet connections normally work OK.
Find all posts by this user
Quote this message in a reply
15-05-2019, 18:41
Post: #6
RE: Minimserver keeps 'disappearing'
Hmmmmm...I actually do have a masters degree in telecoms engineering, but I can't be arsed studying to find out how to make IGMP work :-) Thanks again. I'll report back.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)