Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Timezone incorrect in MinimServer
30-08-2018, 18:09
Post: #1
Timezone incorrect in MinimServer
I have two instances of MinimServer running. Both on a single QNAP 451+. However, the one I run in a Container has the wrong timezone. In the log file it reports the timezone to be Etc/UTC instead of Europe/London as in my other version of MinimServer. Subsequently it thinks it is an hour earlier than it actually is. Can I alter something in the Container to remedy this?
Any help would be appreciated.
Find all posts by this user
Quote this message in a reply
30-08-2018, 20:57
Post: #2
RE: Timezone incorrect in MinimServer
You need to set the correct timezone in the Docker container before starting MinimServer. The simplest way I have found to do this is to add one line to your Dockerfile, as follows:

FROM openjdk:9-jre
EXPOSE 1900/udp 9790 9791
ADD ./MinimServer-0.8.5.2-linux-intel.tar.gz /opt
RUN echo "Europe/London" >/etc/timezone
ENTRYPOINT [ "/bin/sh", "/opt/minimserver/bin/startc" ]

The extra line is the line starting with RUN. After you have done this, you need to delete the MinimServer container and image and recreate both of these using the updated Dockerfile.
Find all posts by this user
Quote this message in a reply
31-08-2018, 20:10
Post: #3
RE: Timezone incorrect in MinimServer
Thanks Simon this has indeed reset the time to what it should be.
I do wonder though if I will need to go through this every time we put the clocks back and forward?
regards
Dave
Find all posts by this user
Quote this message in a reply
31-08-2018, 20:41
Post: #4
RE: Timezone incorrect in MinimServer
I think the container will adjust automatically. We will find out at the end of October.
Find all posts by this user
Quote this message in a reply
01-09-2018, 06:30 (This post was last modified: 01-09-2018 06:31 by timster.)
Post: #5
RE: Timezone incorrect in MinimServer
The EU Commission has recommended scrapping the time change in Europe, staying on summer time all year. If they do, maybe we'll follow suit and the question will go away!
Find all posts by this user
Quote this message in a reply
12-11-2018, 00:01
Post: #6
RE: Timezone incorrect in MinimServer
Just checked after the time change a couple of weeks ago and all seems to be ok without any intervention.
Cheers
Find all posts by this user
Quote this message in a reply
05-09-2020, 20:11
Post: #7
RE: Timezone incorrect in MinimServer
I have now installed MinimServer 2 in a container on my QNAP. All seems to be working EXCEPT that the time is now incorrect again. It is saying GMT so is 1 hour out. I cannot find the Dockerfile to edit as before. Could you point me in the right direction. Many thanks.
Find all posts by this user
Quote this message in a reply
06-09-2020, 08:44
Post: #8
RE: Timezone incorrect in MinimServer
For MinimServer 2, you should add the timezone when you create the container from the image. In Advanced Settings > Environment, click Add and add a new environment variable with name TZ and value Europe/London. I will update the instructions to include this.
Find all posts by this user
Quote this message in a reply
07-09-2020, 11:38
Post: #9
RE: Timezone incorrect in MinimServer
Thank you for the info Simon. Now showing correct time.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)