Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Starting Minimserver on system start
20-04-2018, 19:02
Post: #1
Starting Minimserver on system start
I am running Ubuntu 17.10 (soon 18.04) and want to start Minimserver on system start, rather than manually through terminal.

The program is stored in /opt/minimserver/.

I am unsure how to make it start automatically on boot, especially because it needs SUDO access to do so.

Is there an FAQ or support guide to help me do this?

Marky
Find all posts by this user
Quote this message in a reply
20-04-2018, 21:44 (This post was last modified: 20-04-2018 22:21 by simoncn.)
Post: #2
RE: Starting Minimserver on system start
The guide is in this section.

You need to run minimserver/bin/setup and enable automatic startup (see step 4). Do not use sudo to run this. The setup script will invoke sudo when needed and prompt you for your password.

Edit: You might have problems with this because /opt/minimserver might have root ownership, depending on how you did the installation. To avoid these problems, you can either install MinimServer into /home/your-user-name/minimserver or use chmod +R to change the ownership of /opt/minimserver to your-user-name.
Find all posts by this user
Quote this message in a reply
21-04-2018, 07:35
Post: #3
RE: Starting Minimserver on system start
I can't put Minimserver in /home/user/ as recommended.
More than one user uses this machine.
It has to run outside of the user folder for all and as the system owner, not a user.

I tried the setup instructions but I think they're still designed for upstart or init.d on Linux. They wouldn't work with systemd. :-(
Find all posts by this user
Quote this message in a reply
21-04-2018, 21:39
Post: #4
RE: Starting Minimserver on system start
The setup script uses init.d for autostart if this is available. If init.d is not available, setup uses systemd. On Ubuntu 17.10, init.d is available and the setup script uses it.

To install MinimServer in /opt so that it runs as the root user and starts automatically, do the following:

1) Unpack the .tar.gz file into /opt using sudo tar xf instead of tar xf
2) Run the command: sudo /opt/minimserver/bin/setup enable_autostart root
3) Don't attempt to enable desktop integration for MinimServer. Instead, any user who needs to configure MinimServer should use MinimWatch to do this.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)