Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot skip update
11-04-2018, 22:52
Post: #1
Cannot skip update
I have MinimServer 0.8.5.2 update 122 running on a Raspberry Pi (headless), and control it using MinimWatch on my Windows 7 PC. I tend to close MinimWatch and only run it as needed, typically if I've made changes to my collection and need to refresh the server.

When I run MinimWatch, it apparently checks automatically for updates. If a new MinimServer update is found, a message box appears titled "MinimServer Update Available" with buttons to "Install now" or "Remind me later".

If I click on the "Install now" button, that works as it should. However, if I do not wish to update at this time and click the "Remind me later" button, it closes that message box and immediately pops up another one just like it, so there is no possible way to skip the update. I am forced to click the "Install now" button and continue with the update.

Also, I think there is a similar problem if a new MinimWatch update has been released. I have tried changing the .autoUpdate option in both MinimServer and MinimWatch from "true" (the default) to "false", but it seemed to make no difference. Is this a bug?
Find all posts by this user
Quote this message in a reply
12-04-2018, 07:16
Post: #2
RE: Cannot skip update
It should be possible to choose "Remind me later" to defer or skip the update. I will look into this and post back here.

Setting .autoUpdate to false stops MinimServer and MinimWatch installing updates automatically but doesn't stop the user notification that a new update is available.
Find all posts by this user
Quote this message in a reply
12-04-2018, 19:51
Post: #3
RE: Cannot skip update
(12-04-2018 07:16)simoncn Wrote:  Setting .autoUpdate to false stops MinimServer and MinimWatch installing updates automatically but doesn't stop the user notification that a new update is available.

When .autoUpdate was set to true I never saw anything happen automatically, MinimWatch would still display the update notification and wait for my interaction. I have not seen any difference in behavior between a true and false setting. So what exactly should happen when .autoUpdate is set to true?
Find all posts by this user
Quote this message in a reply
13-04-2018, 08:28
Post: #4
RE: Cannot skip update
If .autoUpdate is set to true (the default setting), MinimServer and MinimWatch check for available updates when they are started. This requires an internet connection. If an update is found, it is installed automatically as part of startup without any confirmation prompt.
Find all posts by this user
Quote this message in a reply
15-04-2018, 02:33
Post: #5
RE: Cannot skip update
OK, so if an update is found, the .autoUpdate option simply determines whether a confirmation prompt will be displayed or not before installing the update.

Since I still got a confirmation prompt even when this option was set to true, something obviously isn't working right.
Find all posts by this user
Quote this message in a reply
15-04-2018, 05:44
Post: #6
RE: Cannot skip update
My autoUpdates are both true, but I'm always prompted when I start MinimWatch on my PC if there's an update to either Watch or Server. No idea if Server is automatically updating when needed on my NAS though as I have it scheduled to restart every morning.
Find all posts by this user
Quote this message in a reply
15-04-2018, 07:02
Post: #7
RE: Cannot skip update
(15-04-2018 02:33)Giarc Wrote:  OK, so if an update is found, the .autoUpdate option simply determines whether a confirmation prompt will be displayed or not before installing the update.

Not exactly. The MinimServer .autoUpdate option causes MinimServer to do an update check (and install the update if one is available) every time MinimServer is started. Similarly, the MinimWatch .autoUpdate option causes MinimWatch to do an update check (and install the update if one is available) every time MinimWatch is started. These .autoUpdate checks never produce a confirmation dialog.

In addition to the above, MinimWatch checks for MinimWatch and MinimServer updates at other times and produces a confirmation dialog if a new update is detected or if there is an uninstalled previously detected update and the .updateReminder interval has expired. Also, if MinimServer is running with a GUI, it does the same thing for MinimServer updates.
Find all posts by this user
Quote this message in a reply
15-04-2018, 16:55
Post: #8
RE: Cannot skip update
I have confirmed that the update dialog works correctly from a remote instance of MinimWatch. To check this on your system, please do the following:

1) Make sure you are running the latest version of MinimWatch (0.8.5.2 with update 60)
2) Perform a clean installation of MinimServer 0.8.5.2 using an SSH window and following the steps in this post
3) In an SSH window, enter the command: minimserver/bin/startc (if not already running)
4) At the '>' prompt, enter the command: prop .autoUpdate=false
5) Accept the license conditions
6) At the '>' prompt, enter the command: exit
7) Enter the command: rm /home/pi/Programs/minimserver/libext/*
8) cd to the /home/pi/Programs directory
9) Enter the command: minimserver/bin/startd

This should start a headless instance of MinimServer on the Pi and produce a MinimWatch update dialog asking if you want to install update 122. Click 'Remind me later' to dismiss the dialog.
Find all posts by this user
Quote this message in a reply
16-04-2018, 04:36
Post: #9
RE: Cannot skip update
(15-04-2018 07:02)simoncn Wrote:  
(15-04-2018 02:33)Giarc Wrote:  OK, so if an update is found, the .autoUpdate option simply determines whether a confirmation prompt will be displayed or not before installing the update.

Not exactly. The MinimServer .autoUpdate option causes MinimServer to do an update check (and install the update if one is available) every time MinimServer is started. Similarly, the MinimWatch .autoUpdate option causes MinimWatch to do an update check (and install the update if one is available) every time MinimWatch is started. These .autoUpdate checks never produce a confirmation dialog.

In addition to the above, MinimWatch checks for MinimWatch and MinimServer updates at other times and produces a confirmation dialog if a new update is detected or if there is an uninstalled previously detected update and the .updateReminder interval has expired. Also, if MinimServer is running with a GUI, it does the same thing for MinimServer updates.

Wow, this auto-update system is complicated and hard to understand! This detailed information does help, plus I've read your documentation on top of that, but it still seems strange that I would get confirmation dialogs even when .autoUpdate was set to true.

I guess that's because MinimServer was running 24/7 on the Pi and rarely got restarted, so the "unprompted" updates never occurred. The confirmation dialogs I saw were from MinimWatch which I assume always shows a confirmation dialog when a MinimServer update is detected.

So this is making more sense to me now, but it's still very odd that after dismissing a confirmation dialog with the "Remind me later" button, another dialog would immediately appear.
Find all posts by this user
Quote this message in a reply
16-04-2018, 04:43
Post: #10
RE: Cannot skip update
(15-04-2018 16:55)simoncn Wrote:  I have confirmed that the update dialog works correctly from a remote instance of MinimWatch. To check this on your system, please do the following:

OK, so I have done this test, but not without some difficulties.

First, I discovered that I was still running MinimWatch 0.8.4 update 57. I had assumed that the update system was keeping it up to date, but apparently not for major updates, so I downloaded the latest version and installed it.

When I ran the new MinimWatch, it prompted me to install update 60. I decided to click the "Remind me later" button just to see what would happen, and guess what? Another dialog immediately appeared! So the same problem is occurring with MinimWatch like I thought. I then went ahead and installed the update.

When I tried to uninstall MinimServer I got some errors:

Removing links for automatic startup...
Acquiring root privilege for system configuration update...
Unrecognized character \xF0; marked by <-- HERE after <-- HERE near column 1 at /usr/share/perl/5.24/strict.pm line 1.
Compilation failed in require at /usr/sbin/update-rc.d line 6.
BEGIN failed--compilation aborted at /usr/sbin/update-rc.d line 6.

So I ran uninstall again and this time I got:

No MinimServer instances are running
Removing MinimServer installation files...
rm: cannot remove '/home/pi/Programs/minimserver/tmp/native/libohNet.so': Permission denied
rm: cannot remove '/home/pi/Programs/minimserver/tmp/native/libohNetJni.so': Permission denied

I ended up having to delete these files manually using sudo.

Now the old installation was finally gone, and I was able to reinstall and complete the test without any further problems. MinimServer produced the correct output, so apparently autoUpdate worked correctly in this case. Also, MinimWatch did produce an update dialog, and the "Remind me later" button worked as it should.

So I think something was messed up on my original MinimServer installation. Hopefully now it's fixed and things should work properly from now on.

There is one thing I'm wondering about. You mentioned "a headless instance" of MinimServer. To me, my server is headless just because I have no monitor or input devices connected. Is there something different with MinimServer on a headless setup? I did originally have desktop integration enabled - does this need to be disabled for a headless configuration? Thanks.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)