Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
convolution with acourate fir filter
14-01-2019, 20:11
Post: #61
RE: convolution with acourate fir filter
(14-01-2019 15:15)simoncn Wrote:  OK, so this would mean you need:

convOut={-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S44.wav -lavfi apad=pad_len=32768,afir,atrim=start_sample=32768}

This is because the Cor1S*.wav setting doesn't work when you use the above setting (starting apad...) for -lavfi. This will be fixed in the next test build.

Yes, you are right: When fixed to a sample rate, this works well. I am then awaiting the next update in order to take full use of both features...

Cheers, SMSWAP
Find all posts by this user
Quote this message in a reply
16-01-2019, 00:51
Post: #62
RE: convolution with acourate fir filter
There is a new test build with a fix for this. To install it, do the following:

1) Select the Packages tab in the Properties window
2) In the 'Other package' tab, type: minimstreamer-0.7.10.3
3) Click Install and follow the prompts to install the package
4) When installation has completed, click Relaunch to relaunch MinimServer and MinimStreamer

With this, you should be able to use the following convOut string:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S*.wav -lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

The quotes are needed because the -lavfi option value contains commas.
Find all posts by this user
Quote this message in a reply
16-01-2019, 07:39
Post: #63
RE: convolution with acourate fir filter
(16-01-2019 00:51)simoncn Wrote:  There is a new test build with a fix for this. To install it, do the following:

1) Select the Packages tab in the Properties window
2) In the 'Other package' tab, type: minimstreamer-0.7.10.3
3) Click Install and follow the prompts to install the package
4) When installation has completed, click Relaunch to relaunch MinimServer and MinimStreamer

With this, you should be able to use the following convOut string:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S*.wav -lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

The quotes are needed because the -lavfi option value contains commas.

That's it Simon: It works very well with varying sample rates/ filters!

Cool stuff: Many thanks to you!

Cheers, Ralf
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)