Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
convolution with acourate fir filter
10-12-2018, 00:27
Post: #51
RE: convolution with acourate fir filter
(09-12-2018 22:10)SMSWAP Wrote:  
(09-12-2018 21:46)simoncn Wrote:  I think the problem is caused by having -version in the convOut string. Please try removing this.

That's it! Many, many thanks Simon!

You have made my day!!!

My apologies for providing poor information that caused you both problems.

I thought I had used that command as part of convout myself but I have found previous notes etc. that showed I had invoked ffmpeg directly with just the -version command.

Glad it is now working for you.
Find all posts by this user
Quote this message in a reply
10-12-2018, 07:27
Post: #52
RE: convolution with acourate fir filter
(10-12-2018 00:27)Alandbush Wrote:  
(09-12-2018 22:10)SMSWAP Wrote:  
(09-12-2018 21:46)simoncn Wrote:  I think the problem is caused by having -version in the convOut string. Please try removing this.

That's it! Many, many thanks Simon!

You have made my day!!!

My apologies for providing poor information that caused you both problems.

I thought I had used that command as part of convout myself but I have found previous notes etc. that showed I had invoked ffmpeg directly with just the -version command.

Glad it is now working for you.

Thanks Alan. Well, it was a learning Big Grin
Find all posts by this user
Quote this message in a reply
13-01-2019, 13:19
Post: #53
RE: convolution with acourate fir filter
Hi Simon & the Other Experts,

while Minim is working absolutely fine with the latest updates, I have tried the recommended changes to suppress the click in-between tracks:

convOut=-i f:\mark_gb\Cor1S44.wav -filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

When applying it, I get an error message (incorrect values). Has anybody tested it?

Cheers, SMSWAP
Find all posts by this user
Quote this message in a reply
13-01-2019, 13:48
Post: #54
RE: convolution with acourate fir filter
Try this instead:

convOut={-i f:\mark_gb\Cor1S44.wav -lavfi apad=pad_len=32768,afir,atrim=start_sample=32768}
Find all posts by this user
Quote this message in a reply
13-01-2019, 14:29
Post: #55
RE: convolution with acourate fir filter
(13-01-2019 13:48)simoncn Wrote:  Try this instead:

convOut={-i f:\mark_gb\Cor1S44.wav -lavfi apad=pad_len=32768,afir,atrim=start_sample=32768}

This gives again the error message: "options incorrect for converter"

Regards, SMSWAP
Find all posts by this user
Quote this message in a reply
13-01-2019, 16:10 (This post was last modified: 13-01-2019 16:10 by simoncn.)
Post: #56
RE: convolution with acourate fir filter
Which version of ffmpeg are you using as the stream converter program?
Find all posts by this user
Quote this message in a reply
13-01-2019, 18:18
Post: #57
RE: convolution with acourate fir filter
(13-01-2019 16:10)simoncn Wrote:  Which version of ffmpeg are you using as the stream converter program?

Version 4.1
Find all posts by this user
Quote this message in a reply
13-01-2019, 21:28
Post: #58
RE: convolution with acourate fir filter
Does the file f:\mark_gb\Cor1S44.wav exist on the machine you are using to run MinimServer?
Find all posts by this user
Quote this message in a reply
14-01-2019, 07:35
Post: #59
RE: convolution with acourate fir filter
(13-01-2019 21:28)simoncn Wrote:  Does the file f:\mark_gb\Cor1S44.wav exist on the machine you are using to run MinimServer?

No. Mine is a QNAP, so the file stream.options looks like this:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S*.wav -lavfi afir

Cheers, SSMWAP
Find all posts by this user
Quote this message in a reply
14-01-2019, 15:15 (This post was last modified: 14-01-2019 15:31 by simoncn.)
Post: #60
RE: convolution with acourate fir filter
OK, so this would mean you need:

convOut={-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S44.wav -lavfi apad=pad_len=32768,afir,atrim=start_sample=32768}

This is because the Cor1S*.wav setting doesn't work when you use the above setting (starting apad...) for -lavfi. This will be fixed in the next test build.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)