Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
convolution with acourate fir filter
09-12-2018, 17:19
Post: #41
RE: convolution with acourate fir filter
Hi Alan,

good point. I have added the -version to the convout command line. This is what Minim log says in response:

17:17:09.921 Thread-12: Monitor response: SaveProperty
17:17:09.921 Thread-12: ErrorMsg=
17:17:09.949 Thread-21: Monitor action: SaveProperty
17:17:09.949 Thread-21: version=1, adapter=192.168.178.23, uriPrefix=http://192.168.178.23:9791/817674e2-696e-4149-8240-d0cb6dc0e979/Upnp/resource/, clientEndpoint=192.168.178.127:50898
17:17:09.949 Thread-21: ComponentName= PropertyName=logLevel PropertyValue=debug
17:17:09.950 Thread-21: saveProperty: compName=null propName=logLevel propValue=debug
17:17:09.959 Thread-21: Monitor response: SaveProperty
17:17:09.959 Thread-21: ErrorMsg=

What does this then say?

Cheers, SMSWAP
Find all posts by this user
Quote this message in a reply
09-12-2018, 17:23
Post: #42
RE: convolution with acourate fir filter
For the sake of completness. These are the settings applied:

stream.converter /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg
stream.options convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav -lavfi afir -version
stream.transcode flac:wav24, wav:wav
Find all posts by this user
Quote this message in a reply
09-12-2018, 17:55 (This post was last modified: 09-12-2018 17:56 by simoncn.)
Post: #43
RE: convolution with acourate fir filter
What kind of file are you playing (FLAC, WAV, etc.)? Your settings will convolve these file types and nothing else.

If you haven't restarted MinimServer since you last changed stream.transcode, try doing this.

Also, try setting the logging level to Debug (it seems you might already have done this), then play a track. Does the log output show that ffmpeg is being invoked?
Find all posts by this user
Quote this message in a reply
09-12-2018, 18:24
Post: #44
RE: convolution with acourate fir filter
Hi Simon,

I am only having FLACs, so this shall work fine for me.

I have restarted Minim a few times. I have also always added the track for playback to the playlist after restart.

In debug mode, I cannot see any FFMPEG activity???
Find all posts by this user
Quote this message in a reply
09-12-2018, 18:37
Post: #45
RE: convolution with acourate fir filter
You need a semicolon after flac:wav24 to trigger the use of FFmpeg instead of MinimStreamer's internal FLAC to WAV converter.
Find all posts by this user
Quote this message in a reply
09-12-2018, 19:15
Post: #46
RE: convolution with acourate fir filter
Done that: flac:wav; ,wav:wav

This now produces a short audible click, but doesn't output any music (even though the control point shows progress indicator)
Find all posts by this user
Quote this message in a reply
09-12-2018, 20:00
Post: #47
RE: convolution with acourate fir filter
It sounds like there might be a problem with your convolution file. Have you checked the debug output in the log to confirm that ffmpeg is being invoked?
Find all posts by this user
Quote this message in a reply
09-12-2018, 21:32
Post: #48
RE: convolution with acourate fir filter
Yes, indeed.

21:29:24.313 Thread-255: LinkBase: adding output filter org.jstreamer.lib.WAVFilter@4d960168
21:29:24.313 Thread-255: ChainImpl: setting property object .@notifyStopped to com.minimstreamer.Streamer$NotifyStopped@377ee733
21:29:24.313 Thread-255: ChainImpl: setting property object .@httpRequest to org.jminim.lib.HTTPConnection$Request@30e37e9e
21:29:24.313 Thread-255: ChainImpl: setting property object .@http to org.jminim.lib.HTTPContext@7788287a
21:29:24.313 Thread-255: ChainImpl: setting property .converter to 'ffmpeg'
21:29:24.313 Thread-255: ChainImpl: setting property .converterCmdEscaped to '/share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg'
21:29:24.313 Thread-255: ChainImpl: setting property .fmtFlt to 'flt'
21:29:24.313 Thread-255: ChainImpl: setting property .convOut to '-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav -lavfi afir -version'
21:29:24.313 Thread-255: ChainImpl: setting property .status to 'HTTP/1.1 206 Partial Content
Find all posts by this user
Quote this message in a reply
09-12-2018, 21:46
Post: #49
RE: convolution with acourate fir filter
I think the problem is caused by having -version in the convOut string. Please try removing this.
Find all posts by this user
Quote this message in a reply
09-12-2018, 22:10
Post: #50
RE: convolution with acourate fir filter
(09-12-2018 21:46)simoncn Wrote:  I think the problem is caused by having -version in the convOut string. Please try removing this.

That's it! Many, many thanks Simon!

You have made my day!!!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)