Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
08-02-2018, 07:59
Post: #1
Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
Need help. I am using BubbleUPnP and minimserver on Synology ds918+ NAS. Everything was working normally. When I play 192kHz/flac/24 bits music files, my DAC shows exactly the same sample rate.

Now lately, when I play the same 192kHz flac files, the BubbleUPnP app shows FFmpeg:WAV/48kHz/16 bits/stereo. My dac also shows WAV/48kHz/16 bits.
It doesn't matter what type of files and sample rate I play, the BubbleUPnP shows FFmpeg:WAV/48kHz/16 bits/stereo. It seem my miniserver is stuck at FFmpeg:WAV/48kHz/16 bits/stereo.

I tried deleting all my stream.transcode and putting "none" in stream.converter. Still the same.
What is going on? Please help Simon.
Find all posts by this user
Quote this message in a reply
08-02-2018, 11:37
Post: #2
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
Are you using BubbleUPnP Server (not the BubbleUPnP control point)? If so, this might be doing the WAV transcoding.
Find all posts by this user
Quote this message in a reply
08-02-2018, 14:53
Post: #3
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(08-02-2018 11:37)simoncn Wrote:  Are you using BubbleUPnP Server (not the BubbleUPnP control point)? If so, this might be doing the WAV transcoding.

Hi Simon. I am using Minimserver and BubbleUPnP control point.
Find all posts by this user
Quote this message in a reply
08-02-2018, 16:35 (This post was last modified: 08-02-2018 16:38 by bubbleguuum.)
Post: #4
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(08-02-2018 07:59)Yitaro Wrote:  Need help. I am using BubbleUPnP and minimserver on Synology ds918+ NAS. Everything was working normally. When I play 192kHz/flac/24 bits music files, my DAC shows exactly the same sample rate.

Now lately, when I play the same 192kHz flac files, the BubbleUPnP app shows FFmpeg:WAV/48kHz/16 bits/stereo. My dac also shows WAV/48kHz/16 bits.
It doesn't matter what type of files and sample rate I play, the BubbleUPnP shows FFmpeg:WAV/48kHz/16 bits/stereo. It seem my miniserver is stuck at FFmpeg:WAV/48kHz/16 bits/stereo.

I tried deleting all my stream.transcode and putting "none" in stream.converter. Still the same.
What is going on? Please help Simon.

That's not caused by MinimServer, but by BubbleUPnP new feature introduced in v2.9 that can decode audio to PCM (similar to MinimStreamer PCM decoding features), either to be able to play unsupported audio formats by the renderer, or to enforce 'max supported samplerate', '16 bit' or stereo for renderers that need it. It can also do ReplayGain. Except for a few known renderers, the defaults are super conservative with a max of 48 kHz / 16 bits / stereo that is guaranteed to play on all renderers.

To change these defaults:

- go to Settings > Individual UPnP/DLNA renderers settings > (pick your renderer in the list)
- set 'Max Samplerate' to unlimited (or 192 kHz)
- disable 'Convert 24-bit to 16-bit'
- if you want multichannel audio unmodified, disable 'Downmix multichannel to stereo'
Find all posts by this user
Quote this message in a reply
08-02-2018, 16:55
Post: #5
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(08-02-2018 16:35)bubbleguuum Wrote:  
(08-02-2018 07:59)Yitaro Wrote:  Need help. I am using BubbleUPnP and minimserver on Synology ds918+ NAS. Everything was working normally. When I play 192kHz/flac/24 bits music files, my DAC shows exactly the same sample rate.

Now lately, when I play the same 192kHz flac files, the BubbleUPnP app shows FFmpeg:WAV/48kHz/16 bits/stereo. My dac also shows WAV/48kHz/16 bits.
It doesn't matter what type of files and sample rate I play, the BubbleUPnP shows FFmpeg:WAV/48kHz/16 bits/stereo. It seem my miniserver is stuck at FFmpeg:WAV/48kHz/16 bits/stereo.

I tried deleting all my stream.transcode and putting "none" in stream.converter. Still the same.
What is going on? Please help Simon.

That's not caused by MinimServer, but by BubbleUPnP new feature introduced in v2.9 that can decode audio to PCM (similar to MinimStreamer PCM decoding features), either to be able to play unsupported audio formats by the renderer, or to enforce 'max supported samplerate', '16 bit' or stereo for renderers that need it. It can also do ReplayGain. Except for a few known renderers, the defaults are super conservative with a max of 48 kHz / 16 bits / stereo that is guaranteed to play on all renderers.

To change these defaults:

- go to Settings > Individual UPnP/DLNA renderers settings > (pick your renderer in the list)
- set 'Max Samplerate' to unlimited (or 192 kHz)
- disable 'Convert 24-bit to 16-bit'
- if you want multichannel audio unmodified, disable 'Downmix multichannel to stereo'
Thank you.
Find all posts by this user
Quote this message in a reply
08-02-2018, 18:17
Post: #6
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(08-02-2018 16:35)bubbleguuum Wrote:  That's not caused by MinimServer, but by BubbleUPnP new feature introduced in v2.9 that can decode audio to PCM (similar to MinimStreamer PCM decoding features), either to be able to play unsupported audio formats by the renderer, or to enforce 'max supported samplerate', '16 bit' or stereo for renderers that need it. It can also do ReplayGain. Except for a few known renderers, the defaults are super conservative with a max of 48 kHz / 16 bits / stereo that is guaranteed to play on all renderers.

Does this mean that BubbleUPnP is streaming the music from MinimServer (i.e., acting as a UPnP renderer), decoding it and then streaming the decoded stream to the user's renderer?
Find all posts by this user
Quote this message in a reply
08-02-2018, 18:57
Post: #7
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(08-02-2018 18:17)simoncn Wrote:  Does this mean that BubbleUPnP is streaming the music from MinimServer (i.e., acting as a UPnP renderer), decoding it and then streaming the decoded stream to the user's renderer?

This is FFmpeg (embedded in BubbleUPnP) streaming from MinimServer (or any other media server, including audio managed by BubbleUPnP as a media server), decoding audio to either WAV or L16 with eventually (depending on renderer specific settings) resampling/bitdepth reduction/conversion to stereo/ReplayGain processing, and the renderer streaming the resulting PCM stream from BubbleUPnP.
All of this is configurable per renderer, and of course it can be entirely disabled. The use case is to be able to play any audio to any renderer and also to handle ReplayGain.
Find all posts by this user
Quote this message in a reply
09-02-2018, 09:29
Post: #8
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
I see the default setting for FFmpeg is to use it for audio formats not natively supported by the renderer. Is this based on the MIME types reported by the renderer? If so, does disabling the MIME type check also disable this? Also, does this work correctly for OpenHome renderers? I am asking this because MIME type matching for multiple server streams was historically not available for OpenHome renderers in BubbleUPnP.

For someone with a number of different renderers, it is a nuisance to need to set UPnP tweaks for each renderer separately. Could there be a global default that can be overridden for individual renderers if required?
Find all posts by this user
Quote this message in a reply
09-02-2018, 13:33 (This post was last modified: 09-02-2018 13:37 by bubbleguuum.)
Post: #9
RE: Minimserver sample rate stuck at WAV/48kHz/16 bits/stereo
(09-02-2018 09:29)simoncn Wrote:  I see the default setting for FFmpeg is to use it for audio formats not natively supported by the renderer. Is this based on the MIME types reported by the renderer?
[/url]

Yes. Other settings (Max samplerate, convert 24-bit to 16-bit, ...) can also enforce transcoding.

(09-02-2018 09:29)simoncn Wrote:  If so, does disabling the MIME type check also disable this?

No, the mime-type check is only performed if you disable FFmpeg decoding entirely for that renderer (which is how it was pre-2.9),
since when FFmpeg is enabled audio is guaranteed to play.


(09-02-2018 09:29)simoncn Wrote:  Also, does this work correctly for OpenHome renderers?

No as it does not make sense for them as they handle their own Playlist and are autonomous. Requiring to leave Android BubbleUPnP running to (eventually) perform FFmpeg decoding would go against this.

However, I'm adding this functionality in OH renderers managed by BubbleUPnP Server for the next update, with FFmpeg decoding done by
BubbleUPnP Server and configuration done in its web config so this functionality can be used with any OH Control point.

There's the exception of the Local OpenHome renderer managed by Android BubbleUPnP which honor FFmpeg settings set in Settings > Local Renderer.

(09-02-2018 09:29)simoncn Wrote:  For someone with a number of different renderers, it is a nuisance to need to set UPnP tweaks for each renderer separately. Could there be a global default that can be overridden for individual renderers if required?

No, there are already way to much setttings in BubbleUPnP and that feature is already confusing users a lot, to the point I'm seriously considering making it by default only enabled for decoding unsupported renderer audio and to disable it for enforcing max supported samplerate / convert to 16 bit / etc which the user will have to explicitely enable if it wants to. The eternal debate of unwanted transcoding vs audio that doesn't play at all...
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)