Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installed OK but can't see my files
02-02-2018, 09:49 (This post was last modified: 02-02-2018 12:54 by TomP.)
Post: #1
Installed OK but can't see my files
Hi, Installation went fine, I transferred the Multimedia folder on my new QNAP TS253A NAS from my old TS112 and installed MinimWatch that shows the path as /share/Multimedia.

Minimserver shows on Linn Kinsky, but no music is shown other than a couple of QNAP samples and the icon is green but I can't see any way to rescan, so what have I missed or need to do now?

[Update] Searching through the forum, I've seen others have had difficulties setting up, so I followed the instructions to alter the indexTags to AlbumArtist and deleted all others than Composer as I get a TagsCustom error message if it is missing. I hit Restart but nothing has appeared and the icon is green. I did find the Rescan control and it has been yellow for about 10min.

[Update 2] Scanning took another 45 min for my 3200 titles and the icon went green. However several albums do not seem to use the Artist tag and display randomly using file names, track titles or CD metadata instead, I did check the tags and they are correct. There is also Miles Davis 'Get Up With It' remasters of which are spread across 2 different 'Complete Session' boxes, 7 on one and one on the other which I had tagged to give me the updated 'Get Up With It' in the correct order. However on Minimserver (either Artist or Album views) they display as 2 albums and the one with 7 titles displays the correct track numbers in the left-pane but plays them in a completely different order, despite the original tagging being confirmed correct.

As a reference, Twonky on my old server does present all 8 tracks in one album although in the same wrong order.

I tried playing around with the indexTags and tagsCustom but nothing changed the incorrect playing of 'Get Up With It, so I think I need help here rather than further playing around in ignorance.

Many thanks...TomP
Find all posts by this user
Quote this message in a reply
02-02-2018, 15:09 (This post was last modified: 02-02-2018 15:10 by simoncn.)
Post: #2
RE: Installed OK but can't see my files
I think you will find that there is some difference between the Artist and/or AlbumArtist tags for disc 1 and disc 2 of this album. This would cause the discs to be split into separate albums by MinimServer but not by Twonky. Another possibility is that the DISCNUMBER tags are missing or incorrect.
Find all posts by this user
Quote this message in a reply
02-02-2018, 16:22
Post: #3
RE: Installed OK but can't see my files
(02-02-2018 15:09)simoncn Wrote:  I think you will find that there is some difference between the Artist and/or AlbumArtist tags for disc 1 and disc 2 of this album. This would cause the discs to be split into separate albums by MinimServer but not by Twonky. Another possibility is that the DISCNUMBER tags are missing or incorrect.

Thanks Simon, that partially fixed it as I did not know there were disk number tags and that corrected to track order on the 7 track disk but there was still a 1 track disk, which had no disk number but fixing that made no difference. The only other difference I could see was different CD dates and CD track numbers were different to the tag track numbers

To fix it all, I copied all tracks to a new folder, gave them the same date and made the file names the same as tag names. Does that make sense?

That leaves the problem of quite a few Albums having Artist names shown that are different to the tag Artist. Any thoughts?

Best Regards...TomP
Find all posts by this user
Quote this message in a reply
02-02-2018, 16:51
Post: #4
RE: Installed OK but can't see my files
(02-02-2018 16:22)TomP Wrote:  To fix it all, I copied all tracks to a new folder, gave them the same date and made the file names the same as tag names. Does that make sense?

Putting all files in the same folder does album matching only on the ALBUM tag and ignores DISCNUMBER, ARTIST and ALBUMARTIST. One of these three tags is the cause of the problem but you have bypassed it.

Quote:That leaves the problem of quite a few Albums having Artist names shown that are different to the tag Artist. Any thoughts?

The Artist index uses the ALBUMARTIST tag if it is present and the ARTIST tag otherwise. To see only your ARTIST tags, use the All Artists index.
Find all posts by this user
Quote this message in a reply
02-02-2018, 18:14
Post: #5
RE: Installed OK but can't see my files
(02-02-2018 16:51)simoncn Wrote:  
(02-02-2018 16:22)TomP Wrote:  To fix it all, I copied all tracks to a new folder, gave them the same date and made the file names the same as tag names. Does that make sense?

Putting all files in the same folder does album matching only on the ALBUM tag and ignores DISCNUMBER, ARTIST and ALBUMARTIST. One of these three tags is the cause of the problem but you have bypassed it.

Quote:That leaves the problem of quite a few Albums having Artist names shown that are different to the tag Artist. Any thoughts?

The Artist index uses the ALBUMARTIST tag if it is present and the ARTIST tag otherwise. To see only your ARTIST tags, use the All Artists index.
I can't see where is the All Artists index so can you help? Thanks
Find all posts by this user
Quote this message in a reply
02-02-2018, 19:14
Post: #6
RE: Installed OK but can't see my files
Do you have All Artists in your indexTags property? It should be there by default unless you have edited indexTags using MinimWatch.
Find all posts by this user
Quote this message in a reply
02-02-2018, 21:47
Post: #7
RE: Installed OK but can't see my files
(02-02-2018 19:14)simoncn Wrote:  Do you have All Artists in your indexTags property? It should be there by default unless you have edited indexTags using MinimWatch.
All I has was Album, Artist, Genre and Composer, so I put in AllArtists (no space) and that seemed to fix all the obvious problems, thanks !!

I am impressed with how little time that rescans take, although is there some background auto-scanning or is it all manual?
Find all posts by this user
Quote this message in a reply
02-02-2018, 23:07 (This post was last modified: 03-02-2018 16:26 by Peter StreamMagic.)
Post: #8
RE: Installed OK but can't see my files
(02-02-2018 21:47)TomP Wrote:  
(02-02-2018 19:14)simoncn Wrote:  Do you have All Artists in your indexTags property? It should be there by default unless you have edited indexTags using MinimWatch.
All I has was Album, Artist, Genre and Composer, so I put in AllArtists (no space) and that seemed to fix all the obvious problems, thanks !!

I am impressed with how little time that rescans take, although is there some background auto-scanning or is it all manual?

You van only do a manual rescan
Find all posts by this user
Quote this message in a reply
02-02-2018, 23:10
Post: #9
RE: Installed OK but can't see my files
(02-02-2018 21:47)TomP Wrote:  
(02-02-2018 19:14)simoncn Wrote:  Do you have All Artists in your indexTags property? It should be there by default unless you have edited indexTags using MinimWatch.
All I has was Album, Artist, Genre and Composer, so I put in AllArtists (no space) and that seemed to fix all the obvious problems, thanks !!

I am impressed with how little time that rescans take, although is there some background auto-scanning or is it all manual?


Rescanning is not automated.
Find all posts by this user
Quote this message in a reply
03-02-2018, 08:16
Post: #10
RE: Installed OK but can't see my files
All Artists should have a space. It doesn't work without one.

The default setting of indexTags doesn't include Album. Did someone else set up MinimServer for you?

There is no background scanning. MinimServer uses a cache to to help with rescan speed and the rescanning code is written very efficiently.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)