Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to transcode dsf to wav24?
01-12-2017, 14:21
Post: #1
How to transcode dsf to wav24?
Hi, I'm using minimiserver/minimstreamer with Jplay/Jplaystreamer.
Some of my dacs are not able to decode dsd streaming, so I'd like to transcode dsd to wav 24 bit 176Khz on the fly with minimstreamer.
In order to do so I've tried to use
dsf:wav24;176, dff:wav24;176
string in streaem.transcode field, but I receive a syntax error, i.e. it seems that minimstreamer doesn't accept those string as a correct one.
Coul you help me, please?
Find all posts by this user
Quote this message in a reply
01-12-2017, 15:00
Post: #2
RE: How to transcode dsf to wav24?
Your syntax is correct but you can't transcode dff to wav24 because this isn't supported by ffmpeg. (I don't know why.) It should work if you specify dsf:wav24;176 with ffmpeg installed.
Find all posts by this user
Quote this message in a reply
01-12-2017, 15:22
Post: #3
RE: How to transcode dsf to wav24?
(01-12-2017 15:00)simoncn Wrote:  Your syntax is correct but you can't transcode dff to wav24 because this isn't supported by ffmpeg. (I don't know why.) It should work if you specify dsf:wav24;176 with ffmpeg installed.

Thanks Simon, I'll try.

I've read about the fact that avconv could be better than ffmpeg, have you tried it?
https://libav.org/download/
Find all posts by this user
Quote this message in a reply
01-12-2017, 16:39
Post: #4
RE: How to transcode dsf to wav24?
I have tried avconv and you can try it as well by installing avconv and specifying avconv instead of ffmpeg in the stream.converter property. The last time I checked, avconv couldn't transcode either dsf or dff to wav but this might have changed.
Find all posts by this user
Quote this message in a reply
01-12-2017, 17:54
Post: #5
RE: How to transcode dsf to wav24?
(01-12-2017 15:00)simoncn Wrote:  Your syntax is correct but you can't transcode dff to wav24 because this isn't supported by ffmpeg. (I don't know why.) It should work if you specify dsf:wav24;176 with ffmpeg installed.

Unfortunately it doesn’t work.

Incorrect encoding rate for output tipe wav24;176;
Find all posts by this user
Quote this message in a reply
01-12-2017, 18:07 (This post was last modified: 01-12-2017 18:08 by simoncn.)
Post: #6
RE: How to transcode dsf to wav24?
You should not have a semicolon after 176.
Find all posts by this user
Quote this message in a reply
01-12-2017, 22:37 (This post was last modified: 01-12-2017 22:39 by grunter.)
Post: #7
RE: How to transcode dsf to wav24?
(01-12-2017 18:07)simoncn Wrote:  You should not have a semicolon after 176.

OK, I've cut the semicolon and there is no error, but when I try to play a dsf the control app (bubble ds) told me dop 352khz and I hear no sound.
I don't understand why.
I've read that the semicolon at the last position of the string told ministreamer not to transcode directly but to use the external transcoder described in the appropriate field.
Is this wrong?
Find all posts by this user
Quote this message in a reply
01-12-2017, 23:08 (This post was last modified: 01-12-2017 23:11 by simoncn.)
Post: #8
RE: How to transcode dsf to wav24?
The semicolon after wav24 does what you said. If you include a sample rate as well (after the semicolon), streaming is always via the external transcoder.

I presume you are using dsf:wav24;176 and not dff:wav24;176. Are you using ffmpeg or avconv?
Find all posts by this user
Quote this message in a reply
01-12-2017, 23:12
Post: #9
RE: How to transcode dsf to wav24?
(01-12-2017 23:08)simoncn Wrote:  The semicolon after wav24 does what you said. If you include a sample rate as well (after the semicolon), streaming is always via the external transcoder.

Are you using dsf:wav24;176 or dff:wav24;176? Are you using ffmpeg or avconv?

I'm using dsf:wav24;176 and ffmpeg.
So why bubble ds told me DoP 352?
I think it would be pcm 176.
Have you got suggestions?
Find all posts by this user
Quote this message in a reply
02-12-2017, 13:38
Post: #10
RE: How to transcode dsf to wav24?
Did you previously have dsf:dopwav as a transcoding option? If so, you might need to restart MinimServer because the transcoding settings are saved as part of the playback URL.

You can check this in BubbleDS by clicking the 3 dots icon for the track you are playing and selecting 'Show metadata'. At the bottom of the list, you will see Stream #1. If the URL ends with $!transcode-dop.wav, the URL needs to be refreshed. The URL should end with $!transcode-24,176.wav
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)