Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Custom MinimServer Installation Not Starting
06-09-2017, 09:29 (This post was last modified: 06-09-2017 09:30 by simoncn.)
Post: #11
RE: Custom MinimServer Installation Not Starting
Thanks for trying this. It eliminates the possibility of the SO_REUSEADDR issue that I had suspected.

This leaves the possibility of another process having bound to the same port number before MinimServer was started. I have been assuming that the relevant port number is 9791 but from reading this thread relating to Plex on unRAID, it seems the conflict could be on port 1900. Please modify your autostart script to run the command netstat -lp to get a list of all listening ports and the processes that are using them.
Find all posts by this user
Quote this message in a reply
06-09-2017, 22:48 (This post was last modified: 06-09-2017 23:01 by Jeeves.)
Post: #12
RE: Custom MinimServer Installation Not Starting
I'm very happy to follow your directions, and greatly appreciate your patience and assistance.

I have altered my start script as you suggested and have attached the output to this post. I also included the ps command in case there was anything of value there. In looking at the output, I am not immediately seeing any references to the port numbers you mention. However, I may not be looking at the information correctly.

Something else I wanted to mention that I noticed when running MinimServer 8.1 (which you probably already know). When I issue the lsof -i command I see that there are two additional references to java with each apparently bound to different ports. The port numbers change when/if MinimServer is restarted. I don't know if this provides any information, but I wanted to point it out (I have added a screenshot to demonstrate).

The link you provided was a great find. I will do some further research to see if I can learn more.

Please let me know if there is anything else you would like me to try - or if you need a break from problem solving Shy

Thanks so much!


Attached File(s) Thumbnail(s)
   

.log  minimserver.log (Size: 2.01 KB / Downloads: 1)
.log  minimserver-crash-20170906-173724.log (Size: 5.67 KB / Downloads: 1)
.log  netstat-output.log (Size: 4.66 KB / Downloads: 2)
.log  ps-output.log (Size: 14.63 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
06-09-2017, 23:43
Post: #13
RE: Custom MinimServer Installation Not Starting
Thanks for this information.

The lsof -i output that you are seeing is normal.

When I start MinimServer 0.8.4, it listens on two addresses/ports:

192.168.0.14:9791 (my external network adapter)
127.0.0.1:9791 (the loopback adapter)

The latter isn't required in a headless environment and might be the reason for the problem if your version of Linux can't handle this. I will think about whether I can work around this somehow.
Find all posts by this user
Quote this message in a reply
07-09-2017, 16:03
Post: #14
RE: Custom MinimServer Installation Not Starting
Thanks so much Simon, I really appreciate it.

In the meantime I will try working with the instructions you provided for building a Docker to test this option.

Have a great weekend!
Find all posts by this user
Quote this message in a reply
19-09-2017, 10:09
Post: #15
RE: Custom MinimServer Installation Not Starting
Hi, I am having installed Minimserver as a test environment on a Ubuntu VM inside of my unRAID server. To maintain a VM just for one app is pretty cumbersome so that a Docker would really appreciated. I am facing the same issue as the thread starter:

docker run -p:1900:1900/udp -p:9790:9790 -p:9791:9791 --net=host minimserver:0.8.4.7
MinimServer 0.8.4.7, Copyright © 2012-2017 Simon Nash. All rights reserved.
autoUpdate: installed package 'minimserver-0.8-update-104'
autoUpdate: relaunching
MinimServer 0.8.4.7 update 104, Copyright © 2012-2017 Simon Nash. All rights reserved.
MinimServer: ohNet port 9791 is already in use
MinimServer: startup error (see crash file for stack trace)

Was there any progress being made since the last posting?

Thanks a lot for the great server!!!
Find all posts by this user
Quote this message in a reply
19-09-2017, 10:53
Post: #16
RE: Custom MinimServer Installation Not Starting
Have you tried starting MinimServer with update 104 already installed, so the autoUpdate doesn't happen?
Find all posts by this user
Quote this message in a reply
19-09-2017, 13:17
Post: #17
RE: Custom MinimServer Installation Not Starting
My understanding was, that 0.8.4.7 already contains the latest version. How do I include the latest update 104 please?
Find all posts by this user
Quote this message in a reply
19-09-2017, 13:53 (This post was last modified: 19-09-2017 13:53 by simoncn.)
Post: #18
RE: Custom MinimServer Installation Not Starting
The first time you run MinimServer, update 104 will be downloaded and installed automatically in the libext directory. If you then run MinimServer with the libext directory already populated, the update will be present already and it will not be reinstalled. I am not sure if it is possible to do this when using Docker.
Find all posts by this user
Quote this message in a reply
19-09-2017, 14:03
Post: #19
RE: Custom MinimServer Installation Not Starting
(19-09-2017 13:53)simoncn Wrote:  The first time you run MinimServer, update 104 will be downloaded and installed automatically in the libext directory. If you then run MinimServer with the libext directory already populated, the update will be present already and it will not be reinstalled. I am not sure if it is possible to do this when using Docker.
No the directory was empty.

I have copy&pasted the content of my running minimserver libext directory into Docker with the following content:
jminim-0.7.108.jar
minim.jar
minimlaunch$-0.7.101.jar
minimreader-0.8.100.jar
minimscript$-0.8.201.jar
minimserver-0.8-update-104.jmpkg
minimserver-0.8.252.jar
minimserver-0.8.4.7.jmpkg
minimui-0.8.222.jar
mscript.jar
mserver.jar
ohnet(linux-x64)-1.10.2315.zip
oldreader-0.8.100.jar

Same result.
Find all posts by this user
Quote this message in a reply
19-09-2017, 17:25
Post: #20
RE: Custom MinimServer Installation Not Starting
What is the smallest hardware configuration that I could use to run unRAID and test this? For example, would it run on a laptop with a single HDD?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)