Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio stations not playing with error code: 501
13-08-2017, 16:22 (This post was last modified: 13-08-2017 16:23 by Pepsican.)
Post: #1
Radio stations not playing with error code: 501
Hi

I have a problem streaming radio stations from an M3U file. Note that when I run the M3U file in Foobar2000, things work fine. The URLs also play in webbrowser, so I am certain it is not the stream location.

Control point: BubbleUPnP
Renderer: mRendu with BubbleUPnP Server installed as OpenHome renderer.
UPnP Tweak: mime-type check is turned off on the control point.
MinimServer & Streamer are the latest version and run on DSM 6.1 with ffmpeg.

When I try to stream a station, I receive "Action failed (Code: 501)". Any ideas what this means? How can I debug this?

Code:
#EXTM3U
#EXTINF:-1, BNR Nieuwsradio, 128kb
http://icecast-bnr.cdp.triple-it.nl:80/bnr_mp3_128_03

#EXTINF:-1, NOS Radio 1, 192kb
http://icecast.omroep.nl:80/radio1-bb-mp3

#EXTINF:-1, 3FM Serious Radio, 192kb
http://icecast.omroep.nl:80/3fm-bb-mp3
Find all posts by this user
Quote this message in a reply
13-08-2017, 19:20 (This post was last modified: 13-08-2017 19:22 by Cebolla.)
Post: #2
RE: Radio stations not playing with error code: 501
Your current M3U file settings are for a direct connection to the internet radio streams and it appears that the microRendu renderer is not able to play them properly.

Instead, you can configure the M3U file to route the internet radio streams via MinimStreamer in order to get it to help the renderer play them. This is described in the "Routing network streams via MinimStreamer" and the "Transcoding" sections of the MinimStreamer User guide:
http://minimstreamer.com/userguide.html

To get you started, one of the first things to try is to see if providing additional audio stream information, such as the audio format, helps. All those streams are in the mp3 audio format, so the following change to the M3U file should route them through MinimStreamer and get MinimStreamer to provide the mp3 audio format additional information in the streams:
Code:
#EXTM3U
#EXTINF:-1,[BNR;mp3] BNR Nieuwsradio, 128kb
http://icecast-bnr.cdp.triple-it.nl:80/bnr_mp3_128_03

#EXTINF:-1,[NOSR1;mp3] NOS Radio 1, 192kb
http://icecast.omroep.nl:80/radio1-bb-mp3

#EXTINF:-1,[3FM;mp3] 3FM Serious Radio, 192kb
http://icecast.omroep.nl:80/3fm-bb-mp3
Find all posts by this user
Quote this message in a reply
13-08-2017, 22:11
Post: #3
RE: Radio stations not playing with error code: 501
The problem might be that these streams are "icecast" and require MinimStreamer processing to remove the icecast metadata from the stream before passing the stream to the renderer.
Find all posts by this user
Quote this message in a reply
14-08-2017, 06:30
Post: #4
RE: Radio stations not playing with error code: 501
(13-08-2017 19:20)Cebolla Wrote:  Your current M3U file settings are for a direct connection to the internet radio streams and it appears that the microRendu renderer is not able to play them properly.

Instead, you can configure the M3U file to route the internet radio streams via MinimStreamer in order to get it to help the renderer play them. This is described in the "Routing network streams via MinimStreamer" and the "Transcoding" sections of the MinimStreamer User guide:
http://minimstreamer.com/userguide.html

To get you started, one of the first things to try is to see if providing additional audio stream information, such as the audio format, helps. All those streams are in the mp3 audio format, so the following change to the M3U file should route them through MinimStreamer and get MinimStreamer to provide the mp3 audio format additional information in the streams:
Code:
#EXTM3U
#EXTINF:-1,[BNR;mp3] BNR Nieuwsradio, 128kb
http://icecast-bnr.cdp.triple-it.nl:80/bnr_mp3_128_03

#EXTINF:-1,[NOSR1;mp3] NOS Radio 1, 192kb
http://icecast.omroep.nl:80/radio1-bb-mp3

#EXTINF:-1,[3FM;mp3] 3FM Serious Radio, 192kb
http://icecast.omroep.nl:80/3fm-bb-mp3

You're good. You're very good!

The file as you included it in your reply is the version that fixed it. Just the tags was not enough. I needed to include the file type.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)