Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer hanging after QNAP 4.3.3 Upgrade
26-09-2017, 04:15
Post: #21
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
I had 192.168.0.0 set as the ohnet.subnet for both MinimServer and MinimWatch.

I'll change my log settings and upload when I get another crash.

(25-09-2017 09:00)simoncn Wrote:  Did you set 192.168.0.0 in the MinimServer properties or the MinimWatch properties? The MinimServer properties are selected by choosing Properties from the minim icon menu. The MinimWatch properties are selected by choosing Options > Properties (watch) from the minim icon menu.

If you are getting a crash with this setting for ohnet.subnet in the MinimServer properties, I would like to see the log. Please enable the debug options that I described in post 7 of this thread. When you get the crash, copy the log to another location and zip it to reduce its size. I will send you a PM describing how to upload the zipped log file to my FTP server.
Find all posts by this user
Quote this message in a reply
26-09-2017, 20:47
Post: #22
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
(25-09-2017 09:00)simoncn Wrote:  Did you set 192.168.0.0 in the MinimServer properties or the MinimWatch properties? The MinimServer properties are selected by choosing Properties from the minim icon menu. The MinimWatch properties are selected by choosing Options > Properties (watch) from the minim icon menu.

If you are getting a crash with this setting for ohnet.subnet in the MinimServer properties, I would like to see the log. Please enable the debug options that I described in post 7 of this thread. When you get the crash, copy the log to another location and zip it to reduce its size. I will send you a PM describing how to upload the zipped log file to my FTP server.

I didn't have these settings. I updated both configurations accordingly.

I'll also upload the log in case I get a new crash.

Thanks
Find all posts by this user
Quote this message in a reply
08-10-2017, 13:18
Post: #23
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
I uploaded the new crash logs. Appreciate if you could have a look.
Find all posts by this user
Quote this message in a reply
08-10-2017, 21:24 (This post was last modified: 08-10-2017 21:28 by simoncn.)
Post: #24
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Thanks for sending this log. Unfortunately, MinimServer was not started with the ohnet.subnet property set. Did you perhaps set this property after starting MinimServer? In this case, MinimServer must be stopped and restarted for this property setting to take effect.

I do have a log from JasonAG with ohnet.subnet set and I will focus my efforts on analysing this log to try to understand the cause of the problem.
Find all posts by this user
Quote this message in a reply
08-10-2017, 22:57
Post: #25
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
I have some idea about why setting the ohnet.subnet property doesn't prevent the problem from happening. I will try to produce a test build to verify this in the next few days.

The other aspect of this is why the crash happens when ohnet.subnet isn't set. This is a different issue and I will work on it after the ohnet.subnet problem has been fixed.
Find all posts by this user
Quote this message in a reply
22-10-2017, 22:39
Post: #26
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
The test build is available now. It should work around the problem if you have ohnet.subnet set correctly. To install it, do the following:

1) In the Properties window. select the Packages tab
2) In the 'Other package' field, type: minimserver-0.8-update-104.1
3) Click Install and follow the prompts to install the package
4) When installation is complete, click Relaunch

Please let me know whether this solves the problem.
Find all posts by this user
Quote this message in a reply
25-10-2017, 21:35
Post: #27
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Any feedback on this fix?
Find all posts by this user
Quote this message in a reply
27-10-2017, 02:28
Post: #28
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
(25-10-2017 21:35)simoncn Wrote:  Any feedback on this fix?

Well, I installed minimserver-0.8-update-104.1 as well as Synology DSM 6.2 beta. Not sure which is helping, but MinimServer has been running without any hiccups for several days now!
Find all posts by this user
Quote this message in a reply
27-10-2017, 09:54
Post: #29
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Thanks for this. I will start work on making this fix part of an official MinimServer build. This takes a bit of time because the ohNet developers will need to apply the fix to the current version of the ohNet code.
Find all posts by this user
Quote this message in a reply
03-11-2017, 12:05
Post: #30
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
The recent MinimServer automatic updates (update 105 and update 106) will remove this fix. To reinstate the fix, please install minimserver-0.8-update-106.1.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)