Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer hanging after QNAP 4.3.3 Upgrade
24-09-2017, 20:20
Post: #11
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Please can you post your complete VPN configuration. I haven't yet used a VPN (it seems now is the time to start) so please don't assume I am familiar with how to set this up.
Find all posts by this user
Quote this message in a reply
24-09-2017, 20:54
Post: #12
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Sure. Sorry I assumed you were familiar.
Here it is:
I use QVPN in QNAP. I am subscribed to NordVPN.
I follow the instructions in the link below to set the profiles in QVPN. The configuration is the same as described.
https://support.nordvpn.com/hc/en-us/art...-NAS-setup
I selected two servers close to my location
1. TCP 443
2. UDP 1194
Find all posts by this user
Quote this message in a reply
24-09-2017, 21:35
Post: #13
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
I use MinimServer on my Synology DS1815+ and have near-daily crashes. I also use NordVPN and have it set to use the default gateway on the remote network.

Simon - If you'd like, I can change my logging level to give you more information?

Thanks,
Jason


(24-09-2017 20:54)Atlantis Wrote:  Sure. Sorry I assumed you were familiar.
Here it is:
I use QVPN in QNAP. I am subscribed to NordVPN.
I follow the instructions in the link below to set the profiles in QVPN. The configuration is the same as described.
https://support.nordvpn.com/hc/en-us/art...-NAS-setup
I selected two servers close to my location
1. TCP 443
2. UDP 1194
Find all posts by this user
Quote this message in a reply
24-09-2017, 21:40 (This post was last modified: 24-09-2017 22:05 by simoncn.)
Post: #14
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Thanks for this information. I will do the NordVPN 3-day free trial, starting later this week, and see how I get on. Does NordVPN just connect your QNAP NAS and not connect other devices on your network? If so, what is the purpose of doing this?

Edit: I have answered my own question by doing some web searching. I see that the QNAP is acting as a gateway for other devices to access the VPN.
Find all posts by this user
Quote this message in a reply
24-09-2017, 21:43
Post: #15
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
(24-09-2017 21:35)JasonAG Wrote:  I use MinimServer on my Synology DS1815+ and have near-daily crashes. I also use NordVPN and have it set to use the default gateway on the remote network.

Simon - If you'd like, I can change my logging level to give you more information?

Thanks,
Jason

Is it the same crash that was reported by Atlantis?

ohNet fatal error: Unhandled exception NetworkAddressInUse at OpenHome/Network.cpp:324 in thread AdapterChange

If so, I don't need any more information about this. If it isn't the same problem, what error message are you seeing?
Find all posts by this user
Quote this message in a reply
24-09-2017, 21:46
Post: #16
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Hi Simon,

Yes, it's the same error message.

Regards,
Jason

(24-09-2017 21:43)simoncn Wrote:  Is it the same crash that was reported by Atlantis?

ohNet fatal error: Unhandled exception NetworkAddressInUse at OpenHome/Network.cpp:324 in thread AdapterChange

If so, I don't need any more information about this. If it isn't the same problem, what error message are you seeing?
Find all posts by this user
Quote this message in a reply
24-09-2017, 22:56
Post: #17
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
How are the addresses 10.8.0.1 and 10.7.7.16 used by the VPN? Are they local addresses for use by client machines or are they remote addresses used internally by QVPN for communicating with the NordVPN server?

It appears the problem occurs when ohNet tries to bind to port 1900 on interface 10.7.7.16 in preparation for sending an SSDP UDP multicast device announcement to all devices on the 10.7.7.x subnet. What other devices would be on the 10.7.7.x subnet?

Before this happens, ohNet is able to do the same thing successfully on the 10.8.0.1 interface. What other devices would be on the 10.8.0.x subnet?
Find all posts by this user
Quote this message in a reply
24-09-2017, 23:15
Post: #18
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Perhaps the problem is that your ovpn file for TCP 443 is using 'proto tcp' and is therefore unable to handle UDP messages. In this case, ohNet should be able to detect the problem and ignore the 10.7.7.16 interface instead of crashing.

Do you actually need to send SSDP device announcements on the 10.8.0.1 and 10.7.7.16 interfaces? If not, you can set the MinimServer ohnet.subnet property to the subnet for your LAN (192.168.1.0) and this should stop the crashes.
Find all posts by this user
Quote this message in a reply
24-09-2017, 23:49
Post: #19
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
I also thought that setting the ohnet.subnet property would help, but it does not. I've had it set to 192.168.0.0 for weeks, and still get crashes.
Find all posts by this user
Quote this message in a reply
25-09-2017, 09:00
Post: #20
RE: MinimServer hanging after QNAP 4.3.3 Upgrade
Did you set 192.168.0.0 in the MinimServer properties or the MinimWatch properties? The MinimServer properties are selected by choosing Properties from the minim icon menu. The MinimWatch properties are selected by choosing Options > Properties (watch) from the minim icon menu.

If you are getting a crash with this setting for ohnet.subnet in the MinimServer properties, I would like to see the log. Please enable the debug options that I described in post 7 of this thread. When you get the crash, copy the log to another location and zip it to reduce its size. I will send you a PM describing how to upload the zipped log file to my FTP server.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)