Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multiple errors in log (paths and tags look ok)
08-06-2017, 20:13 (This post was last modified: 14-06-2017 21:38 by Barbie-qu.)
Post: #1
Multiple errors in log (paths and tags look ok)
NAS: Synology 213 running DSM 6.1.1-15101 Update 4
Music management: MusicBee 3.1.6345

Hi,
I was inspecting my MinimServer log after realising that a lot of tracks were not showing up in my playlists (mainly), and saw that i have a huge number of errors logged.

There are four type i see.
1] incorrect value for DATE tag
2] conflicting ALBUMARTIST values ignored for album 12 Inch Dance: 80s Pop
3] unknown folder for ../../Music_Tom/Various tracks/#. 100 Hz - Catching Spiders.mp3
4] no matching file for ../../Music_Tom/Compilations/Bleep + Warp/Bleep 100 Tracks 2011/10 - Borngräber & Strüver - Dancing Queen.flac

For [1] I am assuming MinimServer only reads dates in a YYYY format. I can fix this in my tags easily enough
For [2] I understand that if two tracks are tagged with the same album, but different album artist then I get this error. This can also be easily fixed.

For [3] and [4] i'm stumped. The 'unknown folder' and 'no matching file' errors form the majority of the errors, and they all occur in *.m3u playlists.
Most other files are indexed without problem in the playlists, and i can't see any obvious differences in the way they are tagged - I'm pretty careful about this.

As background, i create my playlists in MusicBee and save to a folder on my NAS. This folder is then indexed by MinimServer along with two folders that contain my music files.

Any help would be appreciated Smile

Edit: i can see that a lot (but not all) of entries have extended characters which have not been recognised. I know this has been written about elsewhere on the forum, but do you know if there is any issue with MusicBee?
Find all posts by this user
Quote this message in a reply
09-06-2017, 05:29
Post: #2
RE: Multiple errors in log
(08-06-2017 20:13)Barbie-qu Wrote:  Edit: i can see that a lot (but not all) of entries have extended characters which have not been recognised. I know this has been written about elsewhere on the forum, but do you know if there is any issue with MusicBee?

If your playlists contain UTF-8 characters, you need to use .m3u8 as the file extension instead of .m3u.
Find all posts by this user
Quote this message in a reply
10-06-2017, 10:14
Post: #3
RE: Multiple errors in log
Thanks for this tip. Changing the playlist type to .m3u8 has fixed a large number of the errors, leaving me with mainly 'unknown folder' and a few 'no matching file' errors.

e.g.
Error: playlist Auto playlists/Style - Abstract, Downtempo, Future Jazz, Leftfield and Trip Hop.m3u8: unknown folder for ../../Music_Tom/Artist Albums+Tracks/Andy Stott/Luxury Problems/01. Andy Stott - Numb.mp3
Error: playlist Auto playlists/IDM + Downtempo + Future House.m3u8: no matching file for ../../Music_Tom/Compilations/Erased Tapes Collection VIII/07. Ólafur Arnalds & Nils Frahm - 00 26 (Ryan Davis Rethink).mp3

These files definitely exist and can be played through MusiBee without problem, but i can't see what is stopping them being indexed.
Find all posts by this user
Quote this message in a reply
12-06-2017, 00:51
Post: #4
RE: Multiple errors in log
Can you post the complete list of errors if it isn't too long? I might be able to see a pattern for which folders and files are not being found. If there are a lot of errors (more than 100), it would be more convenient to post them as a file attachment.
Find all posts by this user
Quote this message in a reply
12-06-2017, 19:35
Post: #5
RE: Multiple errors in log
Hi Simon,
I've attached the log as requested.


Attached File(s)
.txt  Minimserver log_20170612.txt (Size: 35.2 KB / Downloads: 5)
Find all posts by this user
Quote this message in a reply
13-06-2017, 02:47
Post: #6
RE: Multiple errors in log
Thanks for this. The 'unknown folder' messages are for these folders:

../../Music_Tom/Artist Albums+Tracks
../../Music_Tom/Compilations
D:/TCW/Music/CocoTea

The second path has some garbled characters at the start of the path and this is why MinimServer can't find it.

The third path is incorrect because this is a Windows path and you are running MinimServer on your NAS.

The first path starts with a relative path setting of ../.. and this would be the parent folder of your Static playlists and Auto playlists folders. Whether or not MinimServer can find this folder depends on your folder structure on the NAS and your contentDir settings. What are the full paths on the NAS for the Static playlists, Auto playlists and Music_Tom folders and what are your contentDir settings?

I think it would be best to work on this 'unknown folder' issue first and then investigate the 'no matching file' messages.
Find all posts by this user
Quote this message in a reply
14-06-2017, 21:24 (This post was last modified: 14-06-2017 21:37 by Barbie-qu.)
Post: #7
RE: Multiple errors in log (paths and tags look ok)
Hi Simon,
Here are the directory paths to my music folders on my NAS

contentDir:
/volume1/music/Music_Tom
/volume1/music/Music_Deb
/volume1/music/playlists

Directory paths:
/music/Music_Tom/Artist albums+tracks
/music/Music_Tom/Compilations

/music/playlists/Auto playlists
/music/playlists/Static playlists

Snippet from IDM + Downtempo + Future House.m3u8 playlist showing that the path format for the problem 'Atoms for Peace' files are the same as other files which are correctly indexed.

../../Music_Tom/Compilations/All Tomorrow's Parties/All Tomorrow's Parties 3.0 [Autechre Curated]/CD2/07 - Bola - Magnasushi.flac
../../Music_Tom/Compilations/All Tomorrow's Parties/All Tomorrow's Parties 3.0 [Autechre Curated]/CD2/08 - Pita - Atipfin.flac
../../Music_Tom/Compilations/All Tomorrow's Parties/All Tomorrow's Parties 3.0 [Autechre Curated]/CD2/09 - Baby Ford - Serpentine Tale.flac
../../Music_Tom/Compilations/All Tomorrow's Parties/All Tomorrow's Parties 3.0 [Autechre Curated]/CD2/10 - Hecker - Stocha Acid, Additional Tables, Set 2 Modi Mix.flac
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/01. Atoms For Peace - Before Your Very Eyes....mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/02. Atoms For Peace - Default.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/03. Atoms For Peace - Ingenue.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/04. Atoms For Peace - Dropped.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/05. Atoms For Peace - Unless.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/06. Atoms For Peace - Stuck Together Pieces.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/07. Atoms For Peace - Judge Jury And Executioner.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/08. Atoms For Peace - Reverse Running.mp3
../../Music_Tom/Artist Albums+Tracks/Atoms For Peace/Amok/09. Atoms For Peace - Amok.mp3
../../Music_Deb/Compilations/Back to Mine (Morcheeba)/01 Pony.mp3
../../Music_Deb/Compilations/Back to Mine (Morcheeba)/02 On the Rhodes Again.mp3
../../Music_Deb/Compilations/Back to Mine (Morcheeba)/03 Someday.mp3
../../Music_Deb/Compilations/Back to Mine (Morcheeba)/04 Gris Gris Gumbo Ya Ya.mp3

I suspect that the issue is not the path definition in MinimServer, because 90% of the tracks in these playlists are indexed without errors and show up in various clients.
In case you want to check the tags, here's a link to one of the problem tracks https://www.dropbox.com/s/09xac3x85ii63d...t.mp3?dl=0
Interestingly it throws an error for two of the playlists it's in, but not for a different 'Albums' playlist.

BTW, i'm not worried about the D:/* errors because these are referencing my laptop storage. Just a mistake on my side.
Find all posts by this user
Quote this message in a reply
15-06-2017, 02:58
Post: #8
RE: Multiple errors in log (paths and tags look ok)
Thanks for all this information.

For the track that produces errors in two playlists but not in a third playlist, is the relative path in all three playlists identical? Also, are all three playlists in the same folder?

Please also try changing your contentDir setting to just /volume1/music and doing a rescan. Does this make any difference to the problem?
Find all posts by this user
Quote this message in a reply
16-06-2017, 19:41
Post: #9
RE: Multiple errors in log (paths and tags look ok)
Hi,
I changed the contentDir path to /volume1/music and removed the other paths before rescanning, but the result looks pretty similar to me. There's errors for an extra album that wasn't in the indexed folders previously, but i know why this is.

I was mistaken when i mentioned the track that threw errors in two playlists but not another. One of the playlists does not exist on my server, and the two that do have errors.

I've attached the new log, but there's not much more to go on i'm afraid.


Attached File(s)
.txt  Minimserver log_20170616_contentDir_music.txt (Size: 41.42 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
20-06-2017, 21:23
Post: #10
RE: Multiple errors in log (paths and tags look ok)
Ok, i've been doing some more testing, and here are my findings:

Steps taken:

I created a test playlist of all the files that showed errors.
Then Rescanned
I saw that there was an increase in the number of errors equal to the number of tracks in the test playlist. i.e. rebuilding the playlist from scratch did not mean the tracks indexed correctly without errors.

Within MusicBee I moved one album (Andy Stott) to X:\MinimServerTest\Andy Stott\Luxury Problems
Note: the subfolder structure and file names were unchanged from before. i.e. \Andy Stott\Luxury Problems/01. Andy Stott - Numb.mp3

By moving the files from within MusicBee, all the playlist pointers should be updated as well. To make sure I verified that the path had updated and manually saved the playlist.
I then added /volume1/music/MinimServerTest to contentDir
Rescanned

Result: the album i just moved (Andy Stott) does not show errors for ANY playlists now.

So it looks like the move of location solved the error.
Any ideas? It feels like a bug to me.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)