Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer has stopped working
12-02-2017, 15:39
Post: #1
MinimServer has stopped working
I have just installed the MinimServer update on my PC, and also at the same time a Java update. Now MinimServer cannot play my music. Specifically:
MinimServer shows up as a Media server under Windows.
I have a Marantz system and although network access is fine it cannot detect the MinimServer.
I have a Linn system, same result when using the Kazoo IPad app. I also have Linn Kazoo on my PC and surprisingly it sees MinimServer and can display the music albums and tracks but it cannot play them. It churns and churns.
I have turned on MinimServer verbose logging and there is zero activity when trying to play a music track.
I tried uninstalling and reinstalling the previous version of MinimServer, to no effect.
I reinstalled Java but to no effect.
I don’t know what is happening.
Help. Regards, Michael Kendall
Find all posts by this user
Quote this message in a reply
12-02-2017, 16:43
Post: #2
RE: MinimServer has stopped working
The Java update might have changed your firewall settings. Try completely disabling the Windows firewall to see if this improves things. If it does, you will need to add a firewall rule to allow Java to receive inbound connections.
Find all posts by this user
Quote this message in a reply
12-02-2017, 18:12
Post: #3
RE: MinimServer has stopped working
(12-02-2017 16:43)simoncn Wrote:  The Java update might have changed your firewall settings. Try completely disabling the Windows firewall to see if this improves things. If it does, you will need to add a firewall rule to allow Java to receive inbound connections.
I think that the Java update has made your firewall settings out-of-date, so you need to change them.

The standard MinimServer shortcut points to a jarfile.

Under update 111 a jarfile is started like this:
"C:\Program Files\Java\jre1.8.0_111\bin\javaw.exe" -jar "%1" %*

Under update 121 a jarfile is started like this:
"C:\Program Files\Java\jre1.8.0_121\bin\javaw.exe" -jar "%1" %*

If your firewall settings have been created semi-automatically, as usually happens, then you will have agreed to a firewall exception for "C:\Program Files\Java\jre1.8.0_111\bin\javaw.exe", which isn't going to work now that the javaw executable has moved. If you look in the windows firewall settings, you should find your current java exceptions, possibly listed under Java ™ Platform Binary, and you should be able to correct them.

I'm not sure what causes Windows to ask you to add a firewall setting in the first place, or what stops it from asking again so I don't know why it didn't ask again.

I assume that this will happen every three months - which is the update schedule for Java. There are various ways you could work around this. The most obvious is to open the specific ports that MinimServer requires - these are shown in the MinimWatch properties - usually 9790 and 9791. Otherwise, you'd need to start MinimServer from an executable that didn't change when Java updates - there are Java launchers which can use registry information to locate the Java DLLs. But this would significantly complicate the installation e.g. it would need 32bit and 64 bit versions, depending on which JRE you had (or it would be like BubblleUPNPServer, and require you to have 32bit JRE), whereas the existing scheme simply depends on jarfiles being registered.
Find all posts by this user
Quote this message in a reply
13-02-2017, 09:00
Post: #4
RE: MinimServer has stopped working
(12-02-2017 18:12)skeptic Mike Wrote:  
(12-02-2017 16:43)simoncn Wrote:  The Java update might have changed your firewall settings. Try completely disabling the Windows firewall to see if this improves things. If it does, you will need to add a firewall rule to allow Java to receive inbound connections.
I think that the Java update has made your firewall settings out-of-date, so you need to change them.

The standard MinimServer shortcut points to a jarfile.

Under update 111 a jarfile is started like this:
"C:\Program Files\Java\jre1.8.0_111\bin\javaw.exe" -jar "%1" %*

Under update 121 a jarfile is started like this:
"C:\Program Files\Java\jre1.8.0_121\bin\javaw.exe" -jar "%1" %*

If your firewall settings have been created semi-automatically, as usually happens, then you will have agreed to a firewall exception for "C:\Program Files\Java\jre1.8.0_111\bin\javaw.exe", which isn't going to work now that the javaw executable has moved. If you look in the windows firewall settings, you should find your current java exceptions, possibly listed under Java ™ Platform Binary, and you should be able to correct them.

I'm not sure what causes Windows to ask you to add a firewall setting in the first place, or what stops it from asking again so I don't know why it didn't ask again.

I assume that this will happen every three months - which is the update schedule for Java. There are various ways you could work around this. The most obvious is to open the specific ports that MinimServer requires - these are shown in the MinimWatch properties - usually 9790 and 9791. Otherwise, you'd need to start MinimServer from an executable that didn't change when Java updates - there are Java launchers which can use registry information to locate the Java DLLs. But this would significantly complicate the installation e.g. it would need 32bit and 64 bit versions, depending on which JRE you had (or it would be like BubblleUPNPServer, and require you to have 32bit JRE), whereas the existing scheme simply depends on jarfiles being registered.

That was the problem. I changed the firewall settings and MinimServer now works again. Thanks.
Find all posts by this user
Quote this message in a reply
20-05-2017, 13:37
Post: #5
RE: MinimServer has stopped working
(12-02-2017 16:43)simoncn Wrote:  The Java update might have changed your firewall settings. Try completely disabling the Windows firewall to see if this improves things. If it does, you will need to add a firewall rule to allow Java to receive inbound connections.

THANK YOU SIMONCN. My Windows Firewall had blocked Java - I simply allowed the connection in Properties for both TCP and UDP protocols.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)