Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can max sample rate be specified?
21-12-2016, 20:36 (This post was last modified: 21-12-2016 20:53 by Pepsican.)
Post: #11
RE: Can max sample rate be specified?
(20-12-2016 08:35)simoncn Wrote:  You need a version of ffmpeg that is built with libsoxr. The simplest way to install this is to download a static build from this page and put the ffmpeg file in the MinimServer opt/bin directory (see this section). For the DS414, you need the armhf build.

After copying the ffmpeg file to the Synology, you need to do the following to make the file executable so that MinimStreamer can use it:

1) Use Synology File Station to view the file
2) Right-click the file and select Properties
3) In the Properties dialog, select the Permission tab
4) Select Everyone and click Edit
5) In the Read section, enable Traverse folders/Execute files and click OK
Hi Simon

Although the above instructions should be pretty idiot proof, I still manage to do something wrong. I get the following error message:

MinimStreamer: incorrect FFmpeg version
MinimServer error: now stopped, use 'restart' or 'exit'
MinimServer error: now stopped, use 'restart' or 'exit'

I did the following on my Synology 214+ (which has the same Marvel Armada XP chip as Mike's DS414)
1) Download the armhf file from the website you linked to
2) Copy the file to the NAS
3) Extract the file to MinimServer/opt/bin
4) Change the file name to "ffmpeg" (but fails as well when keeping the name intact)
5) Change the owner to Root (same as the folder owner)
6) In properties, go to Permission and for Everyone enable the Traverse Folder/Execute files permission
7) In Minimwatch, erase the stream.converter property
8) In minimWatch do Restart or Rescan
...and the error message appears...
Find all posts by this user
Quote this message in a reply
21-12-2016, 21:09 (This post was last modified: 21-12-2016 21:40 by Pepsican.)
Post: #12
RE: Can max sample rate be specified?
(21-12-2016 20:36)Pepsican Wrote:  
(20-12-2016 08:35)simoncn Wrote:  You need a version of ffmpeg that is built with libsoxr. The simplest way to install this is to download a static build from this page and put the ffmpeg file in the MinimServer opt/bin directory (see this section). For the DS414, you need the armhf build.

After copying the ffmpeg file to the Synology, you need to do the following to make the file executable so that MinimStreamer can use it:

1) Use Synology File Station to view the file
2) Right-click the file and select Properties
3) In the Properties dialog, select the Permission tab
4) Select Everyone and click Edit
5) In the Read section, enable Traverse folders/Execute files and click OK
Hi Simon

Although the above instructions should be pretty idiot proof, I still manage to do something wrong. I get the following error message:

MinimStreamer: incorrect FFmpeg version
MinimServer error: now stopped, use 'restart' or 'exit'
MinimServer error: now stopped, use 'restart' or 'exit'

I did the following on my Synology 214+ (which has the same Marvel Armada XP chip as Mike's DS414)
1) Download the armhf file from the website you linked to
2) Copy the file to the NAS
3) Extract the file to MinimServer/opt/bin
4) Change the file name to "ffmpeg" (but fails as well when keeping the name intact)
5) Change the owner to Root (same as the folder owner)
6) In properties, go to Permission and for Everyone enable the Traverse Folder/Execute files permission
7) In Minimwatch, erase the stream.converter property
8) In minimWatch do Restart or Rescan
...and the error message appears...

Ok, I found my issue. It is perhaps specific to my circumstances, but it seems the file you download is packaged twice. It wasn't until I did an extract on the extracted extract that I saw the individual files, amongst them, FFMPEG. So, here are some revised instructions to clarify.
1) Download the armhf file from the website Simon linked to (or whatever version is relevant to you)
2) Extract the ffmpeg-release-xxxxxx.tar.xz on your main machine
3) Extract the ffmpeg-release-xxxxxx.tar on your machine. You now see several files (ffmpeg, ffmpeg-10bit, readme.txt, etc.)
4) Copy the ffmpeg file to the NAS (leave the rest. they seem to pertain to video)
5) Change the owner to Root (same as the folder owner)
6) In properties, go to Permission and for Everyone enable the Traverse Folder/Execute files permission
7) In Minimwatch, erase the stream.converter property
8) In minimWatch do Restart or Rescan
It now works.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)