Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ffmpeg + sox transcoding and gapless playback
24-10-2016, 21:49
Post: #11
RE: ffmpeg + sox transcoding and gapless playback
I have not heard this myself and I am unable to say exactly what is causing the problem. Your c) is not quite what I intended to say. My theory (based on some previous experience) is that the renderer cannot cope with too long a time gap between requesting the stream and receiving the start of the stream data. A faster server would reduce this time gap and you could try this as an experiment if you have a faster server available. However, this is not really the correct solution as the correct fix would be to change the renderer to make it less sensitive to such timing issues.

Given that the problem occurs with two different renderers, I am less confident that a renderer issue is the cause. I should be able to set up Volumio on my Raspberry Pi and I will try this to see if I get the same problem.
Find all posts by this user
Quote this message in a reply
24-10-2016, 21:55
Post: #12
RE: ffmpeg + sox transcoding and gapless playback
(24-10-2016 21:49)simoncn Wrote:  ...
Given that the problem occurs with two different renderers, I am less confident that a renderer issue is the cause. I should be able to set up Volumio on my Raspberry Pi and I will try this to see if I get the same problem.

OK, cool. Let me know if there is anything I can provide to help. For what it's worth, all of my test files were Redbook (44.1/16); nothing high-res.
Find all posts by this user
Quote this message in a reply
24-10-2016, 22:03
Post: #13
RE: ffmpeg + sox transcoding and gapless playback
(24-10-2016 21:55)krutsch Wrote:  OK, cool. Let me know if there is anything I can provide to help. For what it's worth, all of my test files were Redbook (44.1/16); nothing high-res.

What exactly do you have in the stream.options and stream.transcode properties?

Which version(s) of ffmpeg/libsoxr are you using?

Are you able to try MinimServer running on something other than a Mac?
Find all posts by this user
Quote this message in a reply
24-10-2016, 22:23
Post: #14
RE: ffmpeg + sox transcoding and gapless playback
(24-10-2016 22:03)simoncn Wrote:  What exactly do you have in the stream.options and stream.transcode properties?

Which version(s) of ffmpeg/libsoxr are you using?

Are you able to try MinimServer running on something other than a Mac?

stream.converter: ffmpeg
stream.options: convOut=-af aresample=resampler=soxr:precision=28
stream.transcode: alac:wav24/-; , mp4:wav24/-; , flac:wav24/-;

ffmpeg and libsoxr are the latest versions built directly from sources, within the last week (I am not at home, so I can't give you the exact version, but can post these tonight).

I really don't have anything in my house but a MacBook Pro and a Mac Mini, so I can't try this with another platform.
Find all posts by this user
Quote this message in a reply
25-10-2016, 03:03
Post: #15
RE: ffmpeg + sox transcoding and gapless playback
(24-10-2016 22:23)krutsch Wrote:  ffmpeg and libsoxr are the latest versions built directly from sources, within the last week (I am not at home, so I can't give you the exact version, but can post these tonight).

ffmpeg version 2.8.3 Copyright © 2000-2015 the FFmpeg developers
built with Apple LLVM version 7.3.0 (clang-703.0.29)
configuration: --prefix=/usr/local/Cellar/ffmpeg/2.8.3 --enable-shared --enable-pthreads --enable-gpl --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-opencl --enable-libx264 --enable-libmp3lame --enable-libvo-aacenc --enable-libxvid --enable-libfdk-aac --enable-libsoxr --enable-nonfree --enable-vda
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100

Office-Mac-Mini:~ ken$ sox --version
sox: SoX v
Find all posts by this user
Quote this message in a reply
25-10-2016, 21:38
Post: #16
RE: ffmpeg + sox transcoding and gapless playback
(24-10-2016 22:23)krutsch Wrote:  stream.transcode: alac:wav24/-; , mp4:wav24/-; , flac:wav24/-;

Please try changing this to the following:

stream.transcode: alac:wav24/-, mp4:wav24/-, flac:wav24/-

and then restart MinimServer. Does this cure the problem?
Find all posts by this user
Quote this message in a reply
26-10-2016, 03:47
Post: #17
RE: ffmpeg + sox transcoding and gapless playback
(25-10-2016 21:38)simoncn Wrote:  Please try changing this to the following:

stream.transcode: alac:wav24/-, mp4:wav24/-, flac:wav24/-

and then restart MinimServer. Does this cure the problem?

No change.
Find all posts by this user
Quote this message in a reply
26-10-2016, 11:29
Post: #18
RE: ffmpeg + sox transcoding and gapless playback
I tried this with the latest Volumio 2.001 on a Raspberry Pi 2 with an IQAudio DAC+.

I thought I heard a slight tick on one track transition but I have not heard this on other transitions.

From looking at the MinimServer debug log, Volumio is loading and buffering the audio data at least 30 seconds before playing it, so the issue when using Volumio is definitely not related to a slower response to a request for audio data when MinimServer is doing on-the-fly transcoding.

Is it possible that the renderer is fetching an album art image from the server when changing to the next track? You could check this by setting the logging level to Debug and observing the MinimServer log window in real time when the transition happens.

A WAV stream produced by on-the-fly transcoding does not contain album art but the original FLAC stream can contain embedded album art. This might be a significant difference. When you did offline conversion from FLAC to WAV, did you set the converter to write album art into the WAV file? If so, you could try doing this without writing album art to see if this makes a difference.
Find all posts by this user
Quote this message in a reply
26-10-2016, 16:50 (This post was last modified: 26-10-2016 16:54 by simoncn.)
Post: #19
RE: ffmpeg + sox transcoding and gapless playback
I tried this again with WAV files that were produced by the method I suggested in this post. I get exactly the same small faint noise with these files. I have no way of knowing whether this is the same tick/pop that you are hearing.

The noise seems like an abrupt drop in the sound level and is definitely not happening when I play FLAC files without transcoding.
Find all posts by this user
Quote this message in a reply
26-10-2016, 17:21
Post: #20
RE: ffmpeg + sox transcoding and gapless playback
I have tried these WAV files on three other renderers and there is no interruption in sound. Because of this, I am convinced that this is a renderer issue.

I know Volumio uses MPD as its renderer software. Perhaps your other renderer uses MPD as well and the problem is in MPD.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)