Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WD MyCloud and Minimserver
24-09-2016, 02:12
Post: #41
RE: WD MyCloud and Minimserver
(11-06-2015 20:29)simoncn Wrote:  
(11-06-2015 19:11)ac16161 Wrote:  Tried this, and although all appeared good in the terminal window, when I re-booted, Minimserver did not automatically start. Tried a couple of times, no joy. Not really an inconvenience though, re-boot events are not that common. For now using startd after a re-boot.

Thanks for letting me know.

It sounds like the My Book Live uses a nonstandard approach for controlling how programs are started automatically at reboot time. Without having a My Book Live for debugging and testing, there's not much I can do to find a solution for this.

The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.
Find all posts by this user
Quote this message in a reply
24-09-2016, 10:16
Post: #42
RE: WD MyCloud and Minimserver
(24-09-2016 02:12)Soli Wrote:  The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.

Please let me know if you find a solution.
Find all posts by this user
Quote this message in a reply
20-10-2016, 05:49 (This post was last modified: 21-10-2016 02:33 by Soli.)
Post: #43
RE: WD MyCloud and Minimserver
(16-09-2016 02:01)Soli Wrote:  
(15-09-2016 17:41)simoncn Wrote:  This is because the current Linux PPC build is compiled for an older level of the PPC architecture to provide compatibility with the MBL.

Have you tried installing and running the MinimServer Linux ARM hard-float download on the Gen 2? You would also need to install the ARM 32-bit hard-float version of Java. What happens if you do this?

Actually I haven't even opened up my new drive. I'll take the plunge one of these days and report back!

Tried it no go. Then I remembered that Gen2 doesn't run Debian. It runs Busybox/some kind of Busybox. So no go.

But the hardware is pretty cool, and a talented individual from another forum has made it easy to replace the busybox crap with Debian.

I'm off to installing Debian (or actually OpenMediaVault) instead of this crappy busybox.

Edit: seems he changed pagesize to 64kb here too, so incompatible with java atm..
Edit2: Seems the pagesize doesn't matter in this case, it uses standard Debian repos and everything seems fine.
Find all posts by this user
Quote this message in a reply
21-10-2016, 02:31 (This post was last modified: 21-10-2016 02:43 by Soli.)
Post: #44
RE: WD MyCloud and Minimserver
Can confirm Minimserver works on the MyCloud Gen2 when replacing the stock software with Debian Jessie. Also works fine with the java from apt-get, so to speak. Autostarts on reboot as expected since this is pure Debian.

I'm going to redo my install and just use stock Debian Jessie and set up samba/minimal java instead of the OMV overkill.
Find all posts by this user
Quote this message in a reply
21-10-2016, 13:35
Post: #45
RE: WD MyCloud and Minimserver
(24-09-2016 10:16)simoncn Wrote:  
(24-09-2016 02:12)Soli Wrote:  The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.

Please let me know if you find a solution.

I tried to hack into the MBL, and it definately uses its own init, or combination of sysv and their own.

I even tried to add "/etc/init.d/minimserver start" to the twonky service file. And even tried to replace the contents of twonky file with minimserver. Still no go (but when I did that, twonky wouldn't start up, so it seems it's using the service file somehow in combination with its own init system)
Find all posts by this user
Quote this message in a reply
07-04-2017, 20:21
Post: #46
RE: WD MyCloud and Minimserver
(24-09-2016 10:16)simoncn Wrote:  
(24-09-2016 02:12)Soli Wrote:  The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.

Please let me know if you find a solution.

Just found out how. I'll make a new thread, since someone might be googling for the same and get confused by the title of this thread.
Find all posts by this user
Quote this message in a reply
10-01-2018, 21:48
Post: #47
RE: WD MyCloud and Minimserver
(24-09-2016 02:12)Soli Wrote:  The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.

on startup the system can't find JAVA
So the simple solution is edit minimserver/bin/startd and add
--------------
JAVA=/shares/Public/Java/ejre1.7.0_75/bin/java
--------------

use you java version
Find all posts by this user
Quote this message in a reply
10-01-2018, 22:15
Post: #48
RE: WD MyCloud and Minimserver
(10-01-2018 21:48)owler Wrote:  on startup the system can't find JAVA
So the simple solution is edit minimserver/bin/startd and add
--------------
JAVA=/shares/Public/Java/ejre1.7.0_75/bin/java
--------------

use you java version

It isn't a good idea to edit the startd file. Instead, create a file named minimstart.conf in the minimserver/etc directory and put the line

JAVA=/shares/Public/Java/ejre1.7.0_75/bin/java

into that file.
Find all posts by this user
Quote this message in a reply
04-02-2018, 13:09
Post: #49
RE: WD MyCloud and Minimserver
(07-04-2017 20:21)Soli Wrote:  
(24-09-2016 10:16)simoncn Wrote:  
(24-09-2016 02:12)Soli Wrote:  The My Book Live seems to use standard Debian SysV init. But for some reason it doesn't start. It does start when I log in and run /etc/init.d/minimserver start. I've tried giving it S99 and adding some required starts as seen in the twonky init file. It also doesn't seem to parce rc.local. Maybe mybooklive is doing it's own custom init. But if you look at some other guides to installing squeezebox server and other things, they are using init.d. Kinda strange but I haven't had time to figure this out yet.

Please let me know if you find a solution.


Just found out how. I'll make a new thread, since someone might be googling for the same and get confused by the title of this thread.

I can't see that new thread, but I have made the init process on my MyBookLive kick off the minimserver.

Here's the net effect of what I did (see below for the twists along the way):

Create the attached file as /etc/init.d/minimserver - note that it refers to the location of the minimserver installation - this may need editting. Then, at the comand prompt:

MyBookLive:~# chmod 755 /etc/init.d/minimserver
MyBookLive:~# ln -s ../init.d/minimserver /etc/rc2.d/S99minimserver


This creates a link from /etc/rc2.d to the executeable file in /etc/init.d
Executeables in rc2.d are run at the second phase of reboot and S99... files are invoked at the last gasp (ie 99th out of 99).

After creating the file & permission & link, the command:

MyBookLive:~# /etc/rc2.d/S99minimserver start

Will start minimserver, and this will be invoked at reboot.

Now the twists: at first, I created the /etc/init.d/minimserver file with the contents "cd /shares/Public/Minim/minimserver/bin && ./startd ; cd -" and on running it for the first time, got the message
Migrating autostart configuration
This is issued by minim, and the file is replaced with contents close to the attached file. However, the PATH doesn't contain Java, so I put this in: "PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

Thanks to all for helping make this work, special thanks to Simon.


.txt  minimserver.txt (Size: 1.82 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
04-02-2018, 22:18
Post: #50
RE: WD MyCloud and Minimserver
Thanks very much for posting this solution.

I would like to make this work "out of the box" if possible, so I have compared your setup with what the minimserver/bin/setup command creates when it is run by the root user. It seems there are two differences:

1) In /etc/rc2.d, you have used S99minimserver instead of S01minimserver

2) You have added the PATH line to ensure that the java executable is found

It should be simple for me to make the first change and I don't think this would cause any problems on other Linux systems. The second change is a bit more problematical because the PATH you have used might not be correct for other systems.

Please try removing the PATH line and creating a minimstart.conf file as described in this post (using the correct path to the java executable on your system). If you do this together with the S99 change, does this enable MinimServer to start automatically?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)