Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer 0.8.2 update 40 temporarily shows error message
01-09-2014, 17:49
Post: #1
MinimServer 0.8.2 update 40 temporarily shows error message
On applying update 40 to the MinimServer installation on my ReadyNAS, error messages were generated, as shown in the following log sequence:

MinimServer 0.8.2 update 40, Copyright © 2012-2014 Simon Nash. All rights reserved.
MinimStreamer 0.4.2, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Embedded Runtime Environment (build 1.7.0_21-b11)
Java HotSpot™ Embedded Client VM (build 23.21-b01, mixed mode)
Platform default charset is UTF-8
Language setting is 'en'
starting MinimServer[Island-NAS]
MinimServer[Island-NAS] is running
MinimServer: 0$=Genre$634 isn't a valid object
MinimServer: 0$=Genre$634 isn't a valid object
MinimServer: 0$=Genre$634 isn't a valid object
stopping MinimServer[Island-NAS]
MinimServer[Island-NAS] is stopped
Language setting is 'en'
starting MinimServer[Island-NAS]
MinimServer[Island-NAS] is running
MinimServer: 0$=Genre$634 isn't a valid object
stopping MinimServer[Island-NAS]
MinimServer[Island-NAS] is stopped
Language setting is 'en'
starting MinimServer[Island-NAS]
MinimServer[Island-NAS] is running

As can be seen, restarting seems to have removed 2 of the 3 error messages, and then the third message did not appear after a rescan. So the problem seems to be resolved. Do the error messages have any particular significance?

My Windows installation of MinimServer did not produce any errors when update 40 was applied.

David
Find all posts by this user
Quote this message in a reply
01-09-2014, 19:22
Post: #2
RE: MinimServer 0.8.2 update 40 temporarily shows error message
(01-09-2014 17:49)DavidHB Wrote:  On applying update 40 to the MinimServer installation on my ReadyNAS, error messages were generated, as shown in the following log sequence:

As can be seen, restarting seems to have removed 2 of the 3 error messages, and then the third message did not appear after a rescan. So the problem seems to be resolved. Do the error messages have any particular significance?

My Windows installation of MinimServer did not produce any errors when update 40 was applied.

David

Thanks for letting me know about this.

Which update level was installed on the ReadyNAS before you applied update 40?

Which control point are you using?
Find all posts by this user
Quote this message in a reply
02-09-2014, 13:46 (This post was last modified: 02-09-2014 18:00 by DavidHB.)
Post: #3
RE: MinimServer 0.8.2 update 40 temporarily shows error message
(13-06-1970 04:32)simoncn,' Wrote:  Which update level was installed on the ReadyNAS before you applied update 40? ... Which control point are you using?

Thank you. From memory, I went from update 36 to update 40 on the NAS, and from update 37 on the Windows installation. The log was generated when I was using the Kazoo control point.

David
Find all posts by this user
Quote this message in a reply
02-09-2014, 13:57
Post: #4
RE: MinimServer 0.8.2 update 40 temporarily shows error message
(02-09-2014 13:46)DavidHB Wrote:  Thank you. From memory, I went from update 36 to update 40 on the NAS, and from update 37 on the Windows installation. The log was generated when I was using the Kazoo control point.

David

The only explanation I can think of is out-of-date cached data in the control point. Please let me know if you see something like this again.
Find all posts by this user
Quote this message in a reply
02-09-2014, 18:26
Post: #5
RE: MinimServer 0.8.2 update 40 temporarily shows error message
Thank you, Simon.

(02-09-2014 13:57)simoncn Wrote:  The only explanation I can think of is out-of-date cached data in the control point.
This makes sense, because in the same use sequence, Kazoo was complaining that it could not connect to the data source (MinimServer on the NAS). Bubble DS was working fine. I took this to be a problem with Kazoo, and, as it cleared itself, did not think any more about it.

Quote:Please let me know if you see something like this again.
Will do. The Kazoo/MinimServer combination is working normally at present.

David
Find all posts by this user
Quote this message in a reply
15-09-2014, 11:36
Post: #6
RE: MinimServer 0.8.2 update 40 temporarily shows error message
I promised to come back if anything like this problem recurred. Here is a log from this morning.

MinimServer 0.8.2 update 42, Copyright © 2012-2014 Simon Nash. All rights reserved.
MinimStreamer 0.4.2, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot™ 64-Bit Server VM (build 23.25-b01, mixed mode)
Platform default charset is windows-1252
Language setting is 'eng'
starting MinimServer[Bridge]
MinimServer[Bridge] is running
Startup complete
restarting MinimServer[Bridge]
Language setting is 'eng'
starting MinimServer[Bridge]
MinimServer[Bridge] is running
restarting MinimServer[Bridge]
Language setting is 'eng'
starting MinimServer[Bridge]
MinimServer[Bridge] is running
MinimServer: 0$=ComposerSort$#20$10082 isn't a valid object
MinimServer: 0$=ComposerSort$#20$10082 isn't a valid object
restarting MinimServer[Bridge]
Language setting is 'eng'
starting MinimServer[Bridge]
MinimServer[Bridge] is running

This time, the error is on my Windows machine, and there were no errors on the NAS. All the logged restarts are associated with rescans.

You can see that the concluding rescan is error-free, so, initially at least, we can rule out MinimServer and/or the metadata as a cause. Unfortunately, the error came up when the log window was not visible; at the time, I was switching between the Kinsky and Kazoo control points, and both were showing their customary reluctance to reconnect after a rescan. As the previous manifestation of this oddity occurred when only Kazoo was in use, that is where the finger seems to point.

David
Find all posts by this user
Quote this message in a reply
15-09-2014, 11:49
Post: #7
RE: MinimServer 0.8.2 update 40 temporarily shows error message
(15-09-2014 11:36)DavidHB Wrote:  You can see that the concluding rescan is error-free, so, initially at least, we can rule out MinimServer and/or the metadata as a cause. Unfortunately, the error came up when the log window was not visible; at the time, I was switching between the Kinsky and Kazoo control points, and both were showing their customary reluctance to reconnect after a rescan. As the previous manifestation of this oddity occurred when only Kazoo was in use, that is where the finger seems to point.

David

It sounds like this is related to the Kazoo problem described in this post.

The message is only a warning. MinimServer has sent the correct error code to the control point and the control point might have detected this and recovered from it. If it happens again, please look at the Kazoo screen to see whether an error is showing there.

I will probably change this to be a verbose or debug message in a future update.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)