Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimserver compatibility
25-08-2014, 22:18
Post: #1
Minimserver compatibility
Hello and thank you in advance for any assistance or guidance. I am not an expert technically or an extremely knowledgable user, but I am fairly familiar in general with computers and with audio gear. I would like to implement a network audio configuration (on an existing Ethernet network) of nas feeding a PS Audio Direct Stream dac with bridge. I would like to control with an ipad and perhaps with the Lightning or Lumin app. The current device serving as a nas is a Western Digital My Cloud Mirror. It is DLNA & UPnP compliant and runs on a Linux base.

Can Minimserver be installed on this nas, or will I need to get something like a Synology?

Any help would be greatly appreciated.
Thanks again.
Find all posts by this user
Quote this message in a reply
26-08-2014, 09:24
Post: #2
RE: Minimserver compatibility
(25-08-2014 22:18)tomtean Wrote:  Hello and thank you in advance for any assistance or guidance. I am not an expert technically or an extremely knowledgable user, but I am fairly familiar in general with computers and with audio gear. I would like to implement a network audio configuration (on an existing Ethernet network) of nas feeding a PS Audio Direct Stream dac with bridge. I would like to control with an ipad and perhaps with the Lightning or Lumin app. The current device serving as a nas is a Western Digital My Cloud Mirror. It is DLNA & UPnP compliant and runs on a Linux base.

Can Minimserver be installed on this nas, or will I need to get something like a Synology?

Any help would be greatly appreciated.
Thanks again.

There isn't a MinimServer installation package for the My Cloud Mirror.

If you are somewhat familiar with Linux commands, it should be possible to login to the NAS using SSH and install the MinimServer Linux ARM download by following the instructions on this page.

I would be interested to hear how you get on with this. If you have any problems or questions, please post here and I will do my best to help.
Find all posts by this user
Quote this message in a reply
27-08-2014, 20:32
Post: #3
RE: Minimserver compatibility
(25-08-2014 22:18)tomtean Wrote:  I would like to implement a network audio configuration (on an existing Ethernet network) of nas feeding a PS Audio Direct Stream dac with bridge. I would like to control with an ipad and perhaps with the Lightning or Lumin app.
tomtean, just a couple of things that might be useful (I have a DirectSteam that I play from a Synology NAS through the Bridge with very good results).

Lightning, Lumin, and Kinsky control points require an OpenHome renderer to work properly. The Bridge unfortunately does not support the OH extensions, and neither will the forthcoming Bridge II (it will play gapless, though). There are a couple other iPad control points, but none of them is perfect. I think there is a thread here somewhere about iPad control points. If you haven't already bought an iPad, you might consider an Android tablet with BubbleUPnP control point.

The sound quality of the DirectStream is just stunning, BTW. Big Grin
Find all posts by this user
Quote this message in a reply
01-12-2015, 18:26 (This post was last modified: 01-12-2015 18:26 by ciccio1112.)
Post: #4
RE: Minimserver compatibility
Hi SimonCn I have a WD my book live you can install minimserver? and if you can you tell me the procedure? Thanks again.

I find minimserver excellent for me indispensable seen transcoding flac wav.
Find all posts by this user
Quote this message in a reply
01-12-2015, 18:44
Post: #5
RE: Minimserver compatibility
(01-12-2015 18:26)ciccio1112 Wrote:  Hi SimonCn I have a WD my book live you can install minimserver? and if you can you tell me the procedure? Thanks again.

I find minimserver excellent for me indispensable seen transcoding flac wav.

See this thread.
Find all posts by this user
Quote this message in a reply
01-12-2015, 23:56 (This post was last modified: 01-12-2015 23:59 by ciccio1112.)
Post: #6
RE: Minimserver compatibility
(01-12-2015 18:44)simoncn Wrote:  
(01-12-2015 18:26)ciccio1112 Wrote:  Hi SimonCn I have a WD my book live you can install minimserver? and if you can you tell me the procedure? Thanks again.

I find minimserver excellent for me indispensable seen transcoding flac wav.

See this thread.

Hi Simon, I run the command

apt-get install openjdk-7-jre-headless

It seemed to work, the output from "java -version" is
java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.7) (7u3-2.1.7-1)
OpenJDK Zero VM (build 22.0-b10, interpreted mode)

but can not upgrade to:

MyBookLive:/shares/Public/Minim/minimserver/bin# java -version
java version "1.7.0_75"
Java™ SE Embedded Runtime Environment (build 1.7.0_75-b13, headless)
Java HotSpot™ Embedded Client VM (build 24.75-b04, mixed mode)

I downloaded the update jre-7u75-FCS-b13-linux-ppc-Headless-18_dec_2014.tar.gz
I unpacked, change the PATH environment variable so I created a link to the /usr/local/bin directory which is already in the PATH

ln -s /shares/Public/Java/ejre1.7.0_75/bin/java /usr/local/bin/java

but I do not know to upgrade to this version
which are commands to be executed to make the upgrade?

I then installed minimserver and gone but minimwatch me the error:

InitParamsJNI: Unable to attach thread to JVM.

Thanks .
Find all posts by this user
Quote this message in a reply
02-12-2015, 10:15 (This post was last modified: 02-12-2015 10:16 by simoncn.)
Post: #7
RE: Minimserver compatibility
I'm a bit confused by the reference to MinimWatch. The first step is to get Java and MinimServer running. What happens when you try to start MinimServer by logging into the My Book Live using ssh and running minimserver/bin/startc? What happens when you run the command java -version?
Find all posts by this user
Quote this message in a reply
02-12-2015, 11:53
Post: #8
RE: Minimserver compatibility
Hi Simon Minimserver is loaded by typing my ip with xxx.xxx.xxx.xxx:9760 I tell me that it can start to see the program Kinsky minimserver but I do not see the music.

when I type java -version tells me:

Java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.7) (7u3-2.1.7-1)
OpenJDK Zero VM (build 22.0-b10, interpreted mode)

I would like to update java but I do not know how to upgrade.

Miniwatch on the bin directory when I type ./startc tells me:

MinimWatch 0.8.3 update 35, Copyright © 2012-2015 Simon Nash. All rights reserved.
Enter command (? For help):
> MinimWatch: can not run multiple instances with the same configuration file Selected media server: MinimWatch
MinimWatch failure: now stopped, use 'relaunch' or 'exit'

Thanks.
Find all posts by this user
Quote this message in a reply
02-12-2015, 12:44
Post: #9
RE: Minimserver compatibility
(02-12-2015 11:53)ciccio1112 Wrote:  Hi Simon Minimserver is loaded by typing my ip with xxx.xxx.xxx.xxx:9760 I tell me that it can start to see the program Kinsky minimserver but I do not see the music.

I think you mean 9790, not 9760. When you type this, do you see the MinimServer status web page? If so, this means MinimServer is running.

If you are seeing MinimServer in Kinsky but you are not seeing your music, you probably need to use the MinimServer status web page to set the correct content directory for your music library.

Quote:when I type java -version tells me:

Java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.7) (7u3-2.1.7-1)
OpenJDK Zero VM (build 22.0-b10, interpreted mode)

I would like to update java but I do not know how to upgrade.

What do you get from typing the command "which java"?

Quote:Miniwatch on the bin directory when I type ./startc tells me:

MinimWatch 0.8.3 update 35, Copyright © 2012-2015 Simon Nash. All rights reserved.
Enter command (? For help):
> MinimWatch: can not run multiple instances with the same configuration file Selected media server: MinimWatch
MinimWatch failure: now stopped, use 'relaunch' or 'exit'

Thanks.

You should not be trying to run MinimWatch on the My Book Live.
Find all posts by this user
Quote this message in a reply
02-12-2015, 12:45
Post: #10
RE: Minimserver compatibility
yes 9790
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)