MinimServer Forum
FFMPEG Audio filters - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: FFMPEG Audio filters (/showthread.php?tid=5377)



FFMPEG Audio filters - lafuente - 07-09-2019 10:06

Hello Simon,

I come close to you because I'd like to know if it is possible to apply specific command line to ffmpeg in minimserver ?

I'd like to test some filters describes here :
https://ffmpeg.org/ffmpeg-filters.html#Audio-Filters

The goal is not to transcode, but rather to use "superequalizer" filter or "treble, highshelf", per example.

Thanks,
Manu


RE: FFMPEG Audio filters - Peter@57m - 07-09-2019 10:48

I think the section at the bottom of the MinimStream User Guide is what you need

https://minimstreamer.com/userguide.html


RE: FFMPEG Audio filters - simoncn - 07-09-2019 11:24

To expand slightly on Peter@57m's reply, the convOut option enables you to specify any FFmpeg filtering options. The user guide page gives some specific examples but is not an exhaustive list.

FFmpeg and convOut are used by MinimStreamer only when transcoding is specified. A typical choice is to set the transcoding output type to WAV (with no change to sample rate and bit depth) as WAV is lossless and works well with all renderers.


RE: FFMPEG Audio filters - lafuente - 07-09-2019 17:32

Thank,

So I tried :

stream.transcode : aiff:wav;, flac:wav;
This seem OK.

After, as sample, I tried :

stream.options : convOut=-lavfi equalizer=f=1000:t=q:w=1:g=2
Seem OK

Then I tried to add a second argument :
stream.options : convOut= -lavfi equalizer=f=1000:t=q:w=1:g=2,equalizer=f=100:t=q:w=2:g=-5
Not OK

Can someone point me where is my mistake ?

thank again


RE: FFMPEG Audio filters - lafuente - 07-09-2019 17:45

And this seem to go :

convOut= -lavfi "equalizer=f=1000:t=q:w=1:g=2,equalizer=f=100:t=q:w=2:g=-5"

At least, minimserver don't tell that the options are not valid


RE: FFMPEG Audio filters - simoncn - 07-09-2019 20:12

You need the double quotes because you have a comma in your convOut string. Without these double quotes, MinimStreamer thinks the text that follows the comma is some other stream.options setting.