MinimServer Forum
Grey icon of Minimwatch, Minimwatch does not see Minimserver - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: Grey icon of Minimwatch, Minimwatch does not see Minimserver (/showthread.php?tid=5296)

Pages: 1 2 3


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 03-06-2019 11:47

Simon,
I use Windows version 10 Home.
Whenever I launched MinimWatch in the past, I never saw a firewall dialog asking whether I wanted to block allow connections to Java. How can I see this dialogue?
Just to be sure, I checked where the programs java.exe, javaw.exe and javaws.exe are located on my PC, and added all these locations manually to the list of allowed Inbound rules. But no improvement. I cannot find *.jar files from Java.

Thank you for advising how to configure Minimserver using console commands. Apologies but I do not understand your instruction:
You could run this command from a Command prompt window: "C:\Program Files\MinimWatch\bin\mscript" -a 192.168.2.10

I tried two ways to follow your advice.

1) The Windows CMD app gives as default directory C:\Users\annek>
When I enter the command mscript, I get the following message:
'mscript' is not recognized as an internal or external command, operable program or batch file.
Should I first go to the folder C:\Program Files\MinimWatch\bin\ ? Which command should I use to go to that folder?
When I enter the command "dir C:\Program Files\MinimWatch\bin" or "dir C:\Program Files\MinimWatch\bin\", the message is "The system cannot find the specified path" whilst for sure it exists!

2) The folder C:\Program Files\MinimWatch\bin\ shows the files "mscript.cmd" and "startc.cmd". When I double click on mscript.cmd or press enter on it, I get a new window with the MScript error message 'C:Users\annek\Appdata\Roaming\Minimserver\data' is not a directory.
When I press "OK", I am back in the directory. How should I execute this CMD line?


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 03-06-2019 12:17

You can run this command from any directory by entering the following exactly as shown:

"C:\Program Files\MinimWatch\bin\mscript" -a 192.168.2.10

The error message about MinimServer\data is a bug. I will post a fix soon.

I think your firewall problems may be caused by an interaction between Norton firewall and Windows firewall that is preventing the dialog being shown. From a quick web search, it seems that Norton firewall has a number of settings that can override Windows firewall settings and it might not be very simple to disable all of these Norton settings.

To get you started, there is information about Firewall Block Notification, Advanced Program Control and Automatic Program Control on this page. There is information about disabling Antivirus Auto-Protect on this page. there is information about disabling Smart Firewall on this page. I suggest you try disabling Smart Firewall, Antivirus Auto-Protect, Advanced Program Control and Automatic Program Control. I cannot provide more help with this as I don't use Norton myself.


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 03-06-2019 12:28

To install a fix for the mscript bug, do the following:

1) Download a new version of mscript.jar from this link

2) Copy this file to the directory C:\Program Files\MinimWatch\lib

3) When prompted, confirm that you want to replace the version of mscript.jar that was installed in this directory by MinimWatch


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 03-06-2019 18:27

Simon,
I successfully copied the new version of mscript.jar into the recommended directory, and it works!
Steps taken:
enter "props" - the list of current settings is shown
enter "prop tagFormat=Title.displayFormat={$tracknumber^^. ^$title^^ / ^^$album}" without the " "
open Minimserver via Firefox
rescan the library
wait until the green symbol Minimserver lights up again, and all tracks are shown in the desired format!

So this works, and thank you for your continuous and quick support.

I will now continue to investigate why MinimWatch stays grey, as I like that little status symbol turning from yellow to green a lot Smile. Again, previously I never had to disable the Firewalls in Norton or Windows Defender to get MinimWatch working, and I did not change any setting. It must be Java 8 update 211.
But when I disable both Firewalls in Norton or Windows Defender it still does not work.

Which begs the question: Am I the only struggling with MinimWatch since upgrading to Java 8 update 211??


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 07-06-2019 20:29

Simon,
I'm pleased to inform you that MinimWatch is working fine again, without the need for disabling Norton Firewall or Windows Defender Firewall. I did not change anything, other than unplugging and rebooting the power supply to the entire home network (a series of routers), the NAS and PC a couple of times.

Whatever the reason was, it is working again, showing a green icon in the bottom right corner of my screen. Thanks again for your support.


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 07-06-2019 21:09

Thanks for letting me know and glad all is well now.


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - vivvih - 11-07-2019 20:51

(03-06-2019 18:27)Gijs Schubert Wrote:  Which begs the question: Am I the only struggling with MinimWatch since upgrading to Java 8 update 211??

Hello Gijs and Simon, I just wanted to tell you that I had the exact same problem today with the grey Minimwatch-icon! Except I didn't use Norton. I was almost going crazy, trying system restore and everything else just like you did. Nothing worked... Then I read your last post about unlugging the router and NAS. Voila! Big Grin Icon is green! Hahaha sometimes the simple things work best.


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 12-07-2019 11:07

Vivvih,
that is great to hear! For days I had been pulling my hairs out, because I could get my beloved green icon on my screen.

A couple of hard resets is sometimes the best!Big Grin


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - ischowam - 25-08-2019 18:10

Hello

Just as an additonal info.

I also was facing the the issue of the grey icon (Minimserver worked well).
Reading this thread I remembered, that I also had updated Java recently.

So I believe, that this had been the reason for it.

For me it was sufficient to delete two incoming rules related to Java in the firewall, which had "blocked" as "action".

After restarting Minimwatch a window popped up with the message, that Java items have been blocked by the firewall and the option to unblock them.

After that the icon became green.

Georg


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 10-09-2019 14:13

Hello Simon,
The icon has turned grey again, and probably the recent Java update is the root cause (although I have no proof for that).
- In Windows Defender I see 3 sets of rules:
- It is enabled on the Domain Network
- It is disabled on the Private Network
- It is enabled on the Guest/Public network
In the incoming rules, there are 4 line items called "Java™ Platform SE binary" of which 2 were not enabled/allowed. I have now enabled/allowed connection.

Norton Firewall is enabled - not sure on which of the 3 above networks. Contrary to last year, I was now able to quickly find the incoming connection rules of Norton, and saw that Norton allows incoming connection for all 4 Java line items. So far so good, but....:

After a reboot of the internet modem, the Wifi router and the Windows PC, unfortunately the icon stays grey.

A right-clicking on the grey icon and then Options > Show log (watch) gives as response:

MinimWatch 0.8.5.3 update 62, Copyright © 2012-2019 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_221-b11)
Java HotSpot™ Client VM (build 25.221-b11, mixed mode, sharing)
Platform default charset is windows-1252
Using single subnet 192.168.1.0
Startup complete

When I try to enter the Minimserver via the webbrower Firefox using the address http://192.168.1.98:9790/ the browser message is: Cannot make a connection.

I will now (like I did as a last resort successfully last year) do a couple of reboots of the entire network, NAS and PC and see what happens...