MinimServer Forum
Grey icon of Minimwatch, Minimwatch does not see Minimserver - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: Grey icon of Minimwatch, Minimwatch does not see Minimserver (/showthread.php?tid=5296)

Pages: 1 2 3


Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 02-06-2019 18:28

Simon,
For unknown reason Minimwatch does not see Minimserver. I am running Minimwatch on a Windows 10 PC and and Firefox as browser. Minimserver is running on a Synology NAS DS112 with DSM version 6.2.2-24922 - which is the latest according to Synology.

Minimserver itself is working fine, the Minimserver symbol is shown on my Naim app and can play all music stored on my NAS via Minimserver & Naim. The NAS DSM app under Network Interface confirms that LAN is working.

Minimwatch has worked fine for the last year. I think the misery started when a new Java version was installed.

I tried to follow all instructions I could find on this forum on 'grey icon'.

I installed the latest Java version 8 update 211 (build 1.8.0_211-b12)

I disabled Windows Defender Firewall and disabled Norton Firewall.

I went to Start > Settings > Network & Internet and confirmed that my home network is being recognised by Windows 10 as a private network.

I then went to Start > Settings and typed "firewall" in the "Find a setting" search box and clicked on the selection named "Windows Defender Firewall". On the new window that opens, I clicked "Advanced settings". In the Advanced settings window, I click Inbound Rules and scroll down to Java ™ Platform SE binary. All the 8 rules in this section say "Private Allow".

The ipconfig /all gives as info:
My IPv4 Address. . . .: 192.168.2.56(Preferred)
The IP address of my Synology NAS is 192.168.2.10
Subnet mask is 255.255.255.0
DHCP is enabled

I re-installed Minimwatch, version MinimWatch-0.8.5.3-install.exe

In Minimwatch under Properties (watch) in the field ohnet.subnet I tested a a couple of IP addresses to see if any of them worked:
192.168.2.56 error message: subnet not found
192.168.2.10 error message: subnet not found
192.168.2.0 error message: subnet not found
When I keep the ohnet.subnet field empty, icon stays gray

The MinimServer Status says:
MinimServer 0.8.5.3 update 128, Copyright © 2012-2019 Simon Nash. All rights reserved.
MinimStreamer 0.7.12, Copyright © 2012-2019 Simon Nash. All rights reserved.
Media server status for MinimServer: Running

My options to solve this problem myself are now exhausted. Could you help me?


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 02-06-2019 20:02

This sounds like it could be a MinimWatch ohnet.subnet problem. You can check the active subnet by selecting Options > Show log (watch) from the grey minim icon. Near the start of the log, there should be a message like this:

Active subnet is 192.168.2.0

Do you see this message? If so, what is the subnet value?


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 02-06-2019 20:41

(02-06-2019 20:02)simoncn Wrote:  This sounds like it could be a MinimWatch ohnet.subnet problem. You can check the active subnet by selecting Options > Show log (watch) from the grey minim icon. Near the start of the log, there should be a message like this:

Active subnet is 192.168.2.0

Do you see this message? If so, what is the subnet value?

Simon,
the message is:
MinimWatch 0.8.5.3 update 62, Copyright © 2012-2019 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_211-b12)
Java HotSpot™ 64-Bit Server VM (build 25.211-b12, mixed mode)
Platform default charset is windows-1252
Active subnet is 192.168.2.0
Startup complete

I entered this IP address 192.168.2.0 in the field ohnet.subnet, then exited MinimWatch, then re-started MinimWatch: icon stays gray. Rebooted the PC: icon stays gray....


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 02-06-2019 20:52

Thansk for confirming this. Your ohnet.subnet setting is correct. This means that the problem is likely to be a firewall setting on your Windows PC. As a test, please try installing Linn Kinsky on your Windows PC. Is Kinsky able to see your MinimServer library?


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 02-06-2019 21:11

Simon,
Linn Kinsky was installed in 10 seconds, and sees my library perfectly. It gives the same information as the Naim app in terms of number of albums, genres, etc.
I can browse through my music library in the same way as I can with the Naim app.

The top line of Kinsky says "http://192.168.2.10:9790/minimserver/....

The MinimWatch icon is still grey though! My objective is restore the previous formatting of track information on the Naim app, which was:
<trackno> <title>/<album> and the artist name on the second line.

Since Minimwatch does not work anymore, I only see <trackno> <title> and the artist name on the second line. The / and the albumtitle are lost, and now all playlists do not "see" the songs anymore.

Grateful if you can help me to restore the functionality of MinimWatch


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 02-06-2019 21:37

This means the Windows firewall (or perhaps your antivirus program) is blocking MinimWatch (Java) but is not blocking Kinsky. This is consistent with the problem starting when you updated Java, as your firewall rules could be allowing connections to the old Java executable but not the new Java executable. This is a common issue after Java updates on Windows.

When you disabled the Windows firewall and the Norton firewall, did you exit and relaunch MinimWatch after doing this? If not, please try doing this.

If this doesn't fix the problem, try the following:

1) Uninstall all versions of Java from your Windows PC

2) Delete all Windows firewall rules and Norton firewall rules that refer to Java

3) Reboot the PC

4) Reinstall the latest version of Java

5) Launch MinimWatch

6) If this still doesn't work, post screenshots showing the Windows firewall rules and Norton firewall rules (if any) that mention Java


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 03-06-2019 07:22

Simon,
Thank you for your support. I did all steps 1)-5) above, and it still does not work with a fresh install of Java 8 update 211.

There are two odd events to mention:
a) since the problem started, MinimWatch never starts automatically after starting the PC, while it is in the start-up menu of Windows10. I have to start MinimWatch manually, which goes fine (but resulting in a grey icon).
b) after I uninstalled Java, removed all Java rules, and reinstalled Java, I checked the Windows Firewall inbound rules. Strangely enough, they do not show up there. I do not understand why inbound rules for Java are not added to the list after reinstallement. Could this block communication between MinimWatch and MinimServer?

In Norton I cannot find a set of firewall rules, so I cannot check if Java is mentioned. It could be that Norton simply uses the Windows Defender Firewall rules.

Anyway, I disabled both the Windows Defender Firewall and the Norton Security Firewall, and still the icon stays gray after rebooting the PC and relaunching, so there should be no blocking. A mistery!

After reinstallating of Java, MinimWatch gets launched and stays grey. The log message is:

MinimWatch 0.8.5.3 update 62, Copyright © 2012-2019 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_211-b12)
Java HotSpot™ 64-Bit Server VM (build 25.211-b12, mixed mode)
Platform default charset is windows-1252
Using single subnet 192.168.2.0
Startup complete


In properties in field ohnet.subnet I have entered 192.168.2.0

It is worth mentioning that I use Firefox 64 bit version as browser, and that the Java website mentiones the following. Could this be related to the problem, or is this unrelated? It is probably unrelated, because I installed Minimwatch in October 2018 using Firefox 64, and it worked very well until 1 June (2 days ago).

Firefox no longer provides NPAPI support (technology required for Java applets)

As of September, 2018, Firefox no longer offers a version which supports NPAPI, the technology required to run Java applets. The Java Plugin for web browsers relies on the cross-platform plugin architecture NPAPI, which had been supported by all major web browsers for over a decade. The 64 bit version of Firefox has never supported NPAPI, and Firefox version 52ESR is the last release to support the technology. It is below the security baseline, and no longer supported.

Java applications are offered through web browsers as either a Java Webstart application (which do not interact with the browser once they are launched) or as a Java Applet (which might interact with the browser). This change does not affect Web Start applications, it only impacts Java Applets.

Developers and System administrators looking for alternative ways to support Firefox users should see this blog regarding Launching Web Start applications.


I need to use MinimWatch/Server to edit the rules for the display of tracks on the Naim app, which I used to do via the menus in MinimWatch. See the attached pictures for the display rules which I kept as pictures from the past, just to be sure Smile. Is there any other way to edit these display rules?

Grateful if you could help me!


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 03-06-2019 09:29

(03-06-2019 07:22)Gijs Schubert Wrote:  b) after I uninstalled Java, removed all Java rules, and reinstalled Java, I checked the Windows Firewall inbound rules. Strangely enough, they do not show up there. I do not understand why inbound rules for Java are not added to the list after reinstallement. Could this block communication between MinimWatch and MinimServer?

This could possibly be significant. If your Windows firewall is set up to block inbound connections by default and there are no rules that provide an exception to allow inbound connections to Java, this could make MinimServer unable to communicate with MinimWatch. This doesn't explain why Kinsky is working, unless there are rules to allow inbound connections to Kinsky. Please check this.

Does the PC have multiple network connections via wired and wireless? Are both of these active or just one? If MinimWatch is currently communicating via wireless, can you try a wired connection only, or vice versa?

You have mentioned Norton Security Firewall. Do you also have Norton antivirus? Some antivirus programs have been reported as interfering with MinimWatch operation. If you do have an antivirus program, try disabling it.

The Java-related changes to Firefox are not relevant to MinimWatch and MinimServer.


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - Gijs Schubert - 03-06-2019 09:57

Simon,
thanks for your quick responses.

I manually added Java to the Inbound rules. In the attached snippit you see the rules for both Java.exe and Javaw.exe (no clue what the difference is, but these rules were also there prior to uninstallment of Java. Under there you see the Kinsky rules. (the text is in Dutch but should be clear to you: Privé = Private, Ja=Yes)

I now disabled both Norton Firewall and Norton Antivirus, but after exiting and restarting Minimwatch, no joy, the icon is still as grey as a "Rainy day in Georgia".
The PC is only connected via wired connections. Windows network status says: "ethernet - private network"
IPv4 address is 192.168.2.56.

Again I would like to note that MinimWatch worked fine from Oct 2018 until 1 June 2019, with unchanged settings for Norton Antivirus, Norton Firewall or Windows Defender Firewall.

What can be wrong with this Java Update 211? Does MinimWatch work fine with other users who have Java update 211 installed?


RE: Grey icon of Minimwatch, Minimwatch does not see Minimserver - simoncn - 03-06-2019 10:54

Are you sure that the paths you have added for Java are the paths that are associated to the .jar filetype in Default Programs? In my firewall, I have rules for multiple Java paths (not just the java vs. javaw part) and I am not sure which one is used when I double-click the MinimWatch launch icon. My Default Programs entry for .jar just says Java TM Platform SE binary and there doesn't seem to be any way to see the path.

As a test, I deleted all my firewall rules for Java and relaunched MinimWatch. This showed the usual firewall dialog asking whether I wanted to block or allow connections to Java. As this is not happening for you, I suspect that your Windows installation may be damaged in some way or there may be an interaction between Norton firewall and Windows firewall that is preventing this dialog being shown. Is there a setting in Norton firewall that says something like "allow Windows firewall to manage connections"?

Are you runnng on Windows 7 or Windows 10? I could try to repeat what you have done (except for Norton firewall) if I know which of these it is.

You asked about an alternative to MinimWatch. You could run this command from a Command prompt window:

"C:\Program Files\MinimWatch\bin\mscript" -a 192.168.2.10

This enables you to enter console commands to configure MinimServer. To show your current properties, use the command:

props

To change the property name propname to the new value propvalue, use the command:

prop propname=propvalue

There is a full description of mscript on this page.