MinimServer Forum
FLAC Files with the ">" Character in File Name Won't Play - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: FLAC Files with the ">" Character in File Name Won't Play (/showthread.php?tid=5159)

Pages: 1 2


FLAC Files with the ">" Character in File Name Won't Play - GreenMtnGringo - 05-01-2019 05:49

Hi Simon, and happy New Year. This is a small issue in the greater scheme of things, but it is interesting and I am hoping you can suggest a solution or workaround. I have numerous FLAC files stored on my Melco N1ZH60 Mk. 1 running the latest version of MinimServer that contain the ">" character in the file name, for example:

"07 - China Cat Sunflower >"

This comes up commonly on FLAC rips of live Grateful Dead CDs. The ">" character at the end of a file name indicates that the the track segues directly into the next track. The problem is that I cannot get these tracks to play using BubbleUPnP or Hi-Fi Cast as control point apps. (Curiously, MP3 files containing the ">" character play fine.)

I could manually rename all of my FLAC tracks containing the ">" character (of which there are many). But given that MP3 files with the same character play fine, I am hoping these is a way to get the FLAC tracks to play, as well.

Thanks very much.


RE: FLAC Files with the ">" Character in File Name Won't Play - simoncn - 05-01-2019 08:28

Happy New Year! Are you transcoding these files? If so, what are your stream.transcode settings?


RE: FLAC Files with the ">" Character in File Name Won't Play - GreenMtnGringo - 05-01-2019 16:25

Hi Simon. Yes, here are my stream.transcode settings:

flac:wav24;

Thanks.


RE: FLAC Files with the ">" Character in File Name Won't Play - simoncn - 06-01-2019 18:18

I have tried this with the same stream.transcode setting as you and a file on my Melco N1 named "07 - China Cat Sunflower >.flac" and the file is playing for me.

Are you sure the file is named as you think? How have you verified the name? When I view a file on the Melco with the above name using Windows Explorer, I see the name 0CW2SZ~H. There could be some name mapping happening that you are not expecting.


RE: FLAC Files with the ">" Character in File Name Won't Play - BlueDog - 06-01-2019 20:12

Maybe a daft question, but if the filename had no extension, would the > char be treated as redirect output?


RE: FLAC Files with the ">" Character in File Name Won't Play - simoncn - 06-01-2019 20:43

No, because the code in MinimStreamer that invokes ffmpeg treats the '>' character correctly. Also, a file with no extension would not be recognized as a FLAC file.


RE: FLAC Files with the ">" Character in File Name Won't Play - BlueDog - 06-01-2019 20:45

(06-01-2019 20:43)simoncn Wrote:  No, because the code in MinimStreamer that invokes ffmpeg treats the '>' character correctly. Also, a file with no extension would not be recognized as a FLAC file.

Thanks - like I said, a daft question. Blush


RE: FLAC Files with the ">" Character in File Name Won't Play - GreenMtnGringo - 07-01-2019 00:11

Hi Simon and BlueDog, and thanks for weighing in. I just tried again to play some of these FLAC files, this time using the mconnectPlayer Lite v3.0.6 app for Android, and I got the same result. So that is three different control point apps that do not work. I have attached a screen shot of how the track names appear when viewing the Melco-stored album folder from my MacBook Pro. The track names look slightly different on the control point apps (see second screen shot of mconnect). In this example, track #s 1, 4 and 5 will not play, whereas tracks 2, 3 and 6 play fine.


RE: FLAC Files with the ">" Character in File Name Won't Play - GreenMtnGringo - 07-01-2019 03:42

Update: I removed my stream.transcode setting ("flac:wav24;") and now the Grateful Dead FLAC files with ">" in the file name are playing using BubbleUPnP.

I enjoy the sound of the "flac:wav24;" transcode setting and it would be great to be able to use it with all files, so any solution or workaround suggestions would be greatly appreciated (but if it cannot be done, I can easily live with renaming the problem files by deleting the ">").

Thanks.


RE: FLAC Files with the ">" Character in File Name Won't Play - simoncn - 07-01-2019 10:43

OK, I understand the problem now. The filename contains the "right-pointing double angle quotation mark" Unicode character 'ยป', not the "greater than" ASCII character '>'. There was a problem with using ffmpeg on the Melco with filenames containing non-ASCII characters in MinimServer 0.8.5.2 and this problem is fixed in the current version 0.8.5.4. See this page for details of how to install 0.8.5.4 on your N1Z.